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1 ABOUT THIS DOCUMENT
This document is a guide and reference for Case Review Administrators who are going to use the
Chronolator Online Workbench to create a new Internal Chronology.

For informa�on about the terminology used in this document (such as Internal Chronology and Local
Administrator), see the Glossary.

OTHER MAJOR DOCUMENTS
Using Chronolator Documents describes how Chronolator facilitates the produc�on of accurate
chronologies, how to combine Chronolator Documents into Composite Chronologies, and the other
tools and features Chronolator provides.

Using Chronolator Samples contains some exercises you can undertake with the sample documents to
acquaint yourself with the main features of Chronolator.

SUPPLEMENTARY DOCUMENTS
The following supplementary documents are available in PDF format.

Chronolator Installa�on Verifica�on Procedure A�er you have downloaded and
unzipped Chronolator you can use the
procedure described in this document
to check the installa�on of the
Chronolator Online Workbench.

Chronolator Version 5.0 Release Notes Summarises the changes made
between Chronolator Versions 4.0 and
5.0.

Ge�ng a non-Chronolator review into Chronolator New customers have o�en already
started a review before they buy a
Chronolator licence. This document
outlines how Chronolator can be used
to improve the process of assembling a
mul�-agency chronology from a
collec�on of non-Chronolator
documents.

Group Policy Se�ngs for Chronolator macros For IT departments, this document
describes Microso� Office Group Policy
Administra�ve Templates that affect
the ability to run macros, and thus the
ability to run Chronolator.
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2 INTRODUCTION
 

2.1 WHAT IS CHRONOLATOR AND WHAT DOES IT DO?
Chronolator was originally wri�en for Microso� Word. It is now complemented by some tools
at tools.chronolator.com that run in a Web browser such as Chrome.

This Help is about Chronolator for Word, apart from the topic Working with the Browser Tools
(sec�on 7).

Chronolator makes it easy to produce and review the chronologies that are needed to review
interac�ons between different agencies and organisa�ons.

Li�le specialist knowledge is required to use it. There are no new programs to learn or install, and only a
basic knowledge of working with Word tables is required.

Chronolator has something to help everyone involved in using a chronology to inves�gate a case:

those who supervise and administer it
the front-line staff who input the data
those who review it

ADMINISTRATORS
Gathering and colla�ng chronologies from mul�ple agencies is a �me consuming task, par�cularly if
they each have different ideas about what they need to provide. Chronolator enforces the standards set
by the administrator (for example, what column headings the chronology table should have) and
automates the merging of individual chronologies.

FRONT-LINE STAFF
Transcribing wri�en records from various sources into a consistent format is a tedious and error-prone
task. Chronolator simplifies the process with a number of tools. There are tools to sort records into
order, to put dates into consistent formats, and to check for a variety of problems.

REVIEWERS
The final objec�ve of a chronology is for someone to make sense of the events it contains. Chronologies
are o�en anonymised, which can make it difficult to build a mental picture of the people involved. The
Chronolator anonymisa�on tool lets you switch back and forth between anonymised and personalised
views of a document.

Other tools for reviewers include:

naviga�ng through a chronology according to entries in the Abbrevia�ons Glossary
reports about items and individuals iden�fied in the Abbrevia�ons Glossary
colour-coding events according to the agency repor�ng them
a calculator to work out the interval between two dates
forma�ng a tabular chronology into a narra�ve layout
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an analysis tool summarising event counts by agency and date

The Chronolator Reviewer's Tool at tools.chronolator.com/review  (one of the Chronolator Browser
Tools) includes many of these features, and also produces graphical �melines. 

THE CHRONOLATOR PROCESS
The Chronolator process begins when the Case Review Administrator sets up an Internal Chronology,
which is a Word document containing a table whose headings and other characteris�cs are specified by
the Administrator.

The Case Review Administrator distributes the Internal Chronology to the various organisa�ons whose
data is required.

If an organisa�on needs to collect data from several departments, the recipient can forward the Internal
Chronology to them and ask them to complete it rather than calling for their original records. Anyone
forwarding a document in this way is called a Local Administrator.

When the holders of the original records have completed their documents, they return them to the
Administrator who wanted the informa�on (either the Case Review Administrator or a Local
Administrator). That Administrator uses Chronolator to merge them into a Composite Chronology.

There is no limit to the number of levels of Local Administra�on.

The diagrams below illustrate the flow of documents between administrators and data collectors.
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MULTIPLE LEVELS OF ADMINISTRATION - SCHEMATIC DOCUMENT FLOW
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MULTIPLE LEVELS OF ADMINISTRATION - A POSSIBLE SCENARIO

2.2 A NOTE ABOUT WORD VERSIONS AND OPTIONS
The illustra�ons in this document were mostly taken in early 2020 using an Office 365 subscrip�on with
a typical set of user op�ons; your own experience might be slightly different. Separate instruc�ons are
provided for each Word version if there are marked differences.

Chronolator documents are supplied in the docm format introduced with Word 2007. They can be
opened in Word XP and 2003 if the Microso� Office Compa�bility Pack is installed. They can be saved in
the old doc format if need be.

LIMITED SUPPORT FOR WORD 2000
Word 2000 is no longer supported by Microso�. Macros in docm files are not supported in Word 2000
even if the Compa�bility Pack is installed. Word 2000 is therefore not suitable if you want to use the
Chronolator Online Workbench.

If you are using Word 2000 and your administrator has sent you an Internal Chronology as a docm file,
ask them to save and send you a doc version.
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WORD FOR APPLE MAC
Chronolator is designed for and tested on Windows versions of Word. It will certainly not work with
Word 2008 for Mac, as it does not include the Visual Basic for Applica�ons programming environment
used to run macros. It might run OK on other versions of Word for Mac, but it is not tested on them and
support is not guaranteed.

HOW CAN I TELL WHICH VERSION OF WORD I AM USING?
The simplest way is to look at the 'splash screen' Word displays while it starts, although this will not
show any difference between Word 2013 and later versions.

Word XP Word 2003 Word 2007 Word 2010 Word 2013 and
later

If you are using Office 365, you can find the exact version by following the instruc�ons at
h�ps://support.microso�.com/en-us/office/about-office-what-version-of-office-am-i-using-932788b8-
a3ce-44bf-bb09-e334518b8b19.

(Short link: h�ps://�nyurl.com/whichOfficeVersion).

2.3 PRACTISE USING CHRONOLATOR
If you want to prac�se using Chronolator you can use the sample files supplied with it alongside the
Using Chronolator Samples Online Help or document.

If you do not have the samples you can download them from
www.chronolator.com/downloads/download-samples.htm.

2.4 GETTING HELP

ONLINE DOCUMENTATION
All the wri�en documents for Chronolator are available online. See About this document (sec�on 1) for a
list of these documents.

VIDEOS
Chronolator provides a number of videos which illustrate its features and how to accomplish many of
the tasks you need to undertake.

See www.chronolator.com/demonstra�ons for feature overviews for prospec�ve purchasers and
reviewers, and www.chronolator.com/tutorials for more detailed explana�ons of individual tasks.
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KNOWLEDGEBASE AND PROBLEM REPORTING
If you cannot find what you need in the above documenta�on and videos, or you want to report a
problem, use the customer portal at support.chronolator.com.

ACCESSING HELP FROM A CHRONOLATOR DOCUMENT
All the above are available using links on the Help bu�on on the Chronolator toolbar.

2.5 SYSTEM REQUIREMENTS

MICROSOFT WORD

Chronolator works with all versions of Word for Windows from XP up, including 64 bit versions where
available.

Macros must be enabled.

See A note about Word versions and op�ons (sec�on 2.2) for informa�on about Word for Mac.
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3 INSTALLING CHRONOLATOR
Chronolator is wri�en in Visual Basic for Applica�ons, which is a standard feature of Microso� Office.
All Chronolator Documents contain the Chronolator so�ware internally, so no special installa�on or
setup procedure is required.

Such as it is, 'installing' Chronolator is simply a ma�er of saving some Word documents on your system,
and then (if you wish) installing a licence.

SYSTEM REQUIREMENTS

MICROSOFT WORD

Chronolator works with all versions of Word for Windows from XP up, including 64 bit versions where
available.

Macros must be enabled.

See A note about Word versions and op�ons (sec�on 2.2) for informa�on about Word for Mac.

DOWNLOADING AND INSTALLING THE ONLINE WORKBENCH
The Chronolator Online Workbench  is used to create the Chronolator Documents you send to agencies
for comple�on.

Instruc�ons about how to download and install it and its related documents are at
www.chronolator.com/download.htm.

DISTRIBUTED CHRONOLATOR DOCUMENTS
People who receive the Chronolator Documents you create do not need to install any so�ware
programs. They merely need to have one of the above versions of Microso� Word.

LICENSING

Chronolator is licensed so�ware. You can evaluate its features without having a licence, but the
Chronologies it creates include a watermark on every page. If you do not want these watermarks to
appear, your Chronolator Document must be licensed.

When you buy a licence to use the Chronolator Online Workbench, you are given a small text file. To
install it, simply copy it into the same folder as the Online Workbench. The Online Workbench
propagates the licence informa�on into the Chronolator Documents it creates.

Details about how to get a licence for the Online Workbench can be found on the Chronolator Web site
at www.chronolator.com.
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4 THE ONLINE WORKBENCH TOOLBAR
When you open the Online Workbench and accept the licence terms, Chronolator creates a new Toolbar
on the Ribbon's Add-Ins tab. Click Add-ins to display it.

If the toolbar does not appear, see The Chronolator toolbar does not appear (sec�on 8.1).

The principal bu�ons in the Online Workbench toolbar allow you to create new Internal and Composite
Chronologies.

The Advanced bu�on provides facili�es that you should normally use only if asked to by Chronolator
support.

The Help bu�on provides links to this Help and other learning tools.
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5 CHRONOLATOR ADMINISTRATION
 

5.1 CHRONOLATOR ADMINISTRATION - AN OVERVIEW
Chronolator adds data checking and manipula�on capabili�es to a document containing Word tables.
This sec�on provides an overview of using it to produce a mul�-agency chronology.

See The Chronolator Process (sec�on 2.1) for an overview of how Word documents are passed around
during the course of a review.

The main steps in using Chronolator are as follows:

Create a blank Internal Chronology document (see Crea�ng a new Internal Chronology Document
(sec�on 5.2))
Distribute the Internal Chronology document to the par�cipa�ng agencies so they can input their
own data (see Distribu�ng the Internal Chronology Document (sec�on 5.3))
Collate the completed Chronology Documents and produce the final Composite Chronology
document (see the Step by Step Guide in the Using Chronolator Documents Help)

If Chronolator encounters a problem, it issues a message. See Appendix B - Chronolator Messages
(sec�on 9.1).

CREATE A BLANK INTERNAL CHRONOLOGY DOCUMENT
When an inves�ga�on is about to begin, you must decide what informa�on needs to be collected and
under what table headings. O�en this decision will be made for you by a Review Panel or similar body.

You create a new Internal Chronology document by using the Chronolator Online Workbench. The
principal component of the Internal Chronology is a table with all the required headings, but it can also
contain a preamble - for example, an explana�on of what the case is about and what sort of informa�on
is required.

See Crea�ng a new Internal Chronology Document (sec�on 5.2) for more details.

DISTRIBUTE THE INTERNAL CHRONOLOGY DOCUMENT
When you have created the Internal Chronology document, you circulate copies of it to the agencies
who need to contribute informa�on to the inves�ga�on. Any convenient medium can be used for
distribu�on: email, CD, or a file sharing Web site for example.

If the document is confiden�al, you can protect it in several ways:

If sending it by physical means, use Royal Mail Signed For or another secure service
If sending electronically, consider using Word’s standard password protec�on features 
(see Protec�ng a document with a password (sec�on 12.3)) and sending the password separately

COLLATE THE COMPLETED CHRONOLOGY DOCUMENTS INTO THE
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COMPOSITE CHRONOLOGY DOCUMENT
As people complete the Internal Chronology, Chronolator ensures that informa�on which you have
deemed mandatory is indeed entered. Documents are automa�cally checked for correct sequence of
dates and �mes. Incomplete or invalid informa�on is highlighted and the user is prompted to make any
necessary correc�ons.

You can begin compiling the Composite Chronology document as soon as completed chronologies start
to come back. There is no need to wait un�l they have all been returned.

Chronolator helps you maintain an audit trail of which Internal Chronologies provided the informa�on in
a Composite Chronology. You say how you want to iden�fy the Internal Chronology you are impor�ng
(for example, Berrickshire Police), and Chronolator adds that iden�fica�on to the Source of Informa�on
column in the Composite Chronology.

As the agencies’ chronologies are imported and merged, you use Chronolator to sort the composite
table by date and �me and to translate the dates and �mes from the various agencies into a consistent
format.

Finally, you can use standard Word features to add any addi�onal forma�ng desired.

Crea�ng Composite Chronologies is described in Crea�ng a Composite Chronology document (sec�on
5.4).

5.2 CREATING A NEW INTERNAL CHRONOLOGY DOCUMENT

OVERVIEW
Crea�ng a new Internal Chronology document involves the following steps:

Decide what column headings you want to appear in the table
Decide which columns must always be completed, and which can be le� blank
Decide how much informa�on you want to use to iden�fy each event in the chronology. Do you just
want the date on which it happened, or also the �me, and possibly the date and �me it finished?
Open the Chronolator Online Workbench and follow the steps shown in the Step by Step guide in
this sec�on

SPECIAL COLUMNS
Chronolator treats most of the columns in a chronology table as free-form text, only checking them if you
deem them mandatory. However, some columns play a major role in the way a Chronolator Document is
processed.

These special columns are briefly described below. You define which ones you want in a document.

Chronolator's names for them are in bold type, but you can give them different headings in the
chronology table.
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EVENT ORDER: DATE, TIME AND SEQUENCE COLUMNS

Up to five special columns can be used to specify when an event happened:

Sequence (op�onal)
Start Date (mandatory for all Chronolator Documents)
Start Time (op�onal)
End Date (op�onal)
End Time (op�onal)

Chronolator can automa�cally populate the Sequence column with event reference numbers. It can also
be used to specify the order of events on a par�cular day when their �mes are unknown.

When Chronolator checks a Chronology Document, it ensures that anything in a Date or Time column is a
valid date or �me, and that all the events are in order (either ascending or descending).

For ease of input, dates can be entered in a variety of formats. For example, all the following will be
recognised:

22.05.16
22-may-16
22/05/16
22/05/2016

Many mistyped dates can also be recognised, e.g. 22.05/16.

Some�mes people might not know exactly when an event occurred. In that case, they can add a ques�on
mark (e.g. ?22 may 2016).  

SOURCE OF INFORMATION COLUMN

It is vital that the source of informa�on about an event is noted. The Source of Informa�on column is
therefore mandatory in all Chronolator Documents. It is the first one a�er the event ordering columns.

To make it easier for people to complete their informa�on, there is no need for them to say what
organisa�on they work for in this column.

For example, suppose someone who works for the Berrick New Town Clinic is entering data from a Health
Visitor’s notes. They need only to record the source of informa�on simply as, say, Health Visitor HV1
diary, not as Berrick New Town Clinic Health Visitor HV1 diary.

When you merge their chronology into a Composite Chronology, Chronolator adds the fact that the
informa�on is from Berrick New Town Clinic to the Source of Informa�on column.

For example, if the
clinic’s document
contains this entry . . .
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. . . a�er you have
imported it, the entry
will look like this:

GLOSSARY COLUMN

A Glossary column can be included which should contain only defined abbrevia�ons - for example,
somebody's ini�als. This can be useful when a chronology contains informa�on pertaining to more than
one person. Chronolator will check that anything in this column has been defined in the Abbrevia�ons
Glossary.

‘MUST FILL’ COLUMNS

You might want to ensure that a par�cular column is always completed for every event. You can do this
when se�ng up the new Internal Chronology document by �cking its Must Fill box in the Case Details
Wizard.

The Start Date and Source of Informa�on columns are always ‘Must Fill’ columns. Whether the other
special columns are is up to you.

CHRONOLATOR DEFAULT COLUMNS AND HEADINGS

By default, Chronolator creates a table with the following headings, which are based on those
recommended in the  London Child Protec�on Procedures.

The only special columns in the default table are the Start Date, Start Time, and Source of Informa�on
columns. As you can see, you can choose whatever you like for their headings: the Start Date and Start
Time columns in the default table are simply headed Date and Time.

STEP BY STEP GUIDE

OPEN THE ONLINE WORKBENCH

Open ChronolatorOnlineWorkbench.docm. You will find it in the ChronologySetup folder.

Macros and the Online Workbench toolbar

Chronolator works by using Word macros. Because they are computer programs, macros can be used to
propagate and run computer viruses. Word therefore allows you to prevent them running, since for most
documents they are unnecessary. However, for Chronolator they are essen�al.
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If macros are allowed to run, Chronolator will ask you to
confirm that you accept the terms of its Licence:

If that does not happen, please refer to Enabling Macros (sec�on 12.1.2).

A�er you press OK to accept the licence terms, the Online Workbench Chronolator toolbar will be added
to the Add-ins tab on the Word Ribbon:

COMPLETE THE CASE DETAILS WIZARD

Click the New Internal
Chronology bu�on on the
Chronolator toolbar:
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The Case Details Wizard appears:

About the Case Details Wizard

There are four main things to know about the Case Details Wizard:

it has several tabs along the top, each of which enables you to set up a different aspect of the
Internal Chronology
you can move from one tab to another by using the bu�ons at the bo�om of the Wizard, or by
clicking on the tab itself
every tab has a panel on the le� describing its purpose
the Finish bu�on is only enabled when you are viewing the Summary tab

The panel on the le� of each tab will usually give you enough informa�on to proceed. If not, you can
find more about the tab in the following parts of this document.
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Model Tab

Using a Model lets you set all
of a chronology’s features in
one go. The fastest way to set
up a Chronolator Document is
to choose a suitable model,
change its Case Reference, click
the Summary tab, and press
Finish.

You can use Chronolator’s
default headings as a
model, or those in an
exis�ng Chronolator
document.

When you have chosen a model, use the other tabs to change individual aspects of the document.

If you make a lot of changes and then decide you do not want them, come back to the Model tab and
press the Reset bu�on to discard them and reload the model.

If you choose the wrong model by mistake, use the Model tab to choose a different one.

Case Reference Tab

If you are running several
reviews at the same �me it can
be difficult to keep track of all
the individual chronologies you
receive. Giving each case a
unique Case Reference helps
prevent you from accidentally
merging chronologies from
different cases. If you try to do
so, Chronolator will warn you
about it.

The Case Reference is not displayed in the document itself.

Chronolator tries to ensure every case reference is unique by se�ng it to the date and �me you
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started the Case Details Wizard. However, you can change it to whatever you want.

Sequencing and Source Tab

This is where you set the
headings describing when an
event occurred, and where the
informa�on about it came
from.

As a minimum, Chronolator
requires that every event has a
Start Date and Source of
Informa�on; the relevant
boxes are �cked and cannot be
un-�cked.

You can set the text displayed in the column headings. In this example, the Start Date column will
actually be headed Date.

If you want to include any other event ordering columns, �ck the appropriate box and enter some text
for their headings.

If you want a column always to be completed, �ck its Must Fill box.

Chronolator defaults to having an op�onal Start Time column (its Must Fill box is not �cked).
Without a Start Time column, if people want to enter a �me they generally try to put it  in the next
most relevant column , which is the Date one - and Chronolator then flags the date as an error.
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General Headings Tab

You can specify up to eight
general headings for each
event, but you should
remember that the more
columns you have, the more
cramped the table will be, even
though it is presented in
Landscape format.

To add a new heading, type it
in the box at the bo�om and
press Add.

To change where a column
appears, click on it and use the
up or down arrow bu�ons.

To delete a heading, click on it
and press Delete.

Must-Fill Columns Tab

When you want a par�cular
column always to be
completed, �ck the box against
it on this tab.

In this example, the Response
or Outcome column has to be
completed for every event.

Be careful before making a column ‘Must Fill’ - if people really have nothing appropriate to include
in the column they will have to enter 'n/a' or something in it to prevent Chronolator flagging an
error; or they might ignore other errors along with those ones.
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Abbrevia�ons Tab

A Chronolator Document can
contain an Abbrevia�ons
Glossary. Each abbrevia�on can
be up to ten characters long,
and its defini�on up to thirty.

People can see the
abbrevia�ons you define, and
can add and delete their own
by using the Admin >
Abbrevia�ons bu�on on the
Internal or Composite
Chronology toolbar. They
cannot delete abbrevia�ons
you have defined.

How you use the glossary is up to you. It can just be an informa�on repository for reference and
recommenda�on, or it can be included in Chronolator error checking by including a Glossary column. It
can also be used by the Anonymisa�on and Personalisa�on feature, and by a reviewer who wants to
navigate through a document finding people of interest.

Using a Glossary column

If you want to make sure that any abbrevia�ons an agency uses are defined in the glossary, you
can create a Glossary column by �cking the Check Glossary box and entering a column heading. As with
any column, you can say whether or not it has to be filled by �cking the Must Fill  box.

A Glossary column is placed a�er the Source of Informa�on column.
 

Abbrevia�ons used in other columns are not checked by Chronolator, though they do par�cipate in
Anonymisa�on and Personalisa�on.

 

As an example, consider a case involving several family members. You want every event in the
chronology to include informa�on about which members were involved.
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You would define their ini�als
in the glossary and provide a
Glossary column. In this
example, abbrevia�ons have
been defined for various
rela�onships (Younger brother,
Father), organisa�ons
(Department for Educa�on,
Clinical Commissioning Group),
and an individual (Tony
Sedgefield). Because Check
Glossary is �cked and Column
Heading is completed,
Chronolator will create a
column headed Inits. As Must
Fill is �cked, it must always be
filled. Chronolator will check
that it only contains
abbrevia�ons (or their
defini�ons) that are in the
glossary.           

User-defined glossary entries

Agencies might also want to iden�fy their personnel in an anonymous way - HV1 for a Health Visitor
called Marion West for example. They can add their own abbrevia�ons to the glossary as they complete
a Chronolator Document.

When Chronolator merges chronologies, it keeps track of where each abbrevia�on was defined.

Anonymisa�on and Personalisa�on

The Abbrevia�ons Glossary is also used to Anonymise and Personalise a document, and to navigate
through a document finding people of interest. See Anonymisa�on and Personalisa�on in the Using
Chronolator Documents Help for details.
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Summary Tab

When you have entered all the
details you want, click on the
Summary tab to see exactly
what you have defined. If you
need to make any changes, use
the appropriate tab and then
come back to the Summary tab
for a final check.

When everything is OK, press
the Finish bu�on.

Save the document

               
When you press the Finish bu�on in the
Case Details Wizard, Chronolator creates
an Internal Chronology to your
specifica�ons and asks you where to
save it and what to call it.

Choose a suitable loca�on and file name
and press Save.

In recent years some email systems (notably the NHS in the UK) have blocked the .docm file type
that is the default used by Chronolator. You can avoid this problem by saving a document with the
.doc file type; do this by changing Word Macro-Enabled Document (*.docm) in the above Save As
dialog to Word 97-2003 document (*.doc).

For the most up-to-date informa�on about email transmission, see this FAQ item on the Chronolator
Web site (www.chronolator.com/faq.htm#c8-email01 or �nyurl.com/macroVirus01).
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Update the preamble

A�er the new Internal Chronology is saved, Chronolator opens it so you can edit the preamble.

The preamble is above the chronology
table. It describes the document, says
who it should be returned to, and
provides some informa�on about
Chronolator.

Chronolator does not check or process
the preamble in any way; you can put
whatever you want in it, or even delete
it. For example, if you intend to
distribute the Internal Chronology to the
various agencies by email, you could
include the preamble in the email and
a�ach an Internal Chronology containing
only the table. It is up to you.

It makes sense to tell people how you expect each column to be used. Chronolator generates a What
to put in the table sec�on in the preamble describing each column, including any informa�on about
what checks Chronolator will make. You can update this table with any informa�on or instruc�ons
you like.

Final checks

Make sure the table column headings are exactly what you want and have no typos. If you need to
change them, do not do so in this document, but go back to the Online Workbench and create
another Internal Chronology using this document as a model.

Before you send out the document, close and re-open it, and press the Check Tables bu�on on its
Chronolator toolbar. There should be no problems, but if there are it is be�er that you find and fix them
now rather than have your recipients all complaining to you!

Crea�ng a file for the Chronolator Data Entry Browser Tool

If you want to create a file that your partner agencies can complete using the online Chronolator Data
Entry Tool (one of the Chronolator Browser Tools) instead of Word,  use the Publish > JSON bu�on in the
new Internal Chronology to produce a JSON file to send to them.

If you want to protect the chronology with a password,  do not circulate the JSON file. Instead:

open it in the Data Entry tool
add a password using the facility on the Se�ngs tab
save the result using the Save as text bu�on on the Finish tab
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send the result to your partners

More details about exchanging data with the Chronolator Browser Tools can be found in the Working with
the Browser Tools (sec�on 7) and Incorpora�ng the Browser Tools into your workflow (sec�on 7.1) topics.

Changing the preamble for all Internal Chronologies

You can make permanent changes to the preamble text if you want - for example, to put your own
contact details in it. The preamble text is kept in ChronolatorMasterChronologyText.docx, a Word
document in the same ChronologySetup folder as the Online Workbench. You can edit it and save your
changes, and they will be incorporated in any new Internal Chronologies.

5.3 DISTRIBUTING THE INTERNAL CHRONOLOGY DOCUMENT
An Internal Chronology document can be distributed just like any other document. Most organisa�ons
do so by email, but CDs, USB s�cks, and file sharing sites are all valid methods of distribu�on.

In recent �mes, distribu�ng Chronolator for Word documents by email has become less convenient
as email providers seek to reduce the number of computer viruses circulated in macro-enabled
documents. Consider sending a file that can be read by the Chronolator Data Entry tool -
see Working with the Browser Tools (sec�on 7) for details.
There are also some other circumven�ons for this: please refer to the FAQ on the Chronolator Web
site for the most up-to-date informa�on.

 

As an Internal Chronology includes all the program code required to run the various tools and features
of Chronolator, it also includes informa�on about the Chronolator licence. You do not need to, nor
should you, distribute your Online Workbench licence file to other agencies.

If the document is confiden�al, you can protect it in several ways:

Use your organisa�on's standard policy for such emails
If sending it by physical means, use Royal Mail Signed For or another secure service
If sending electronically, consider using Word’s standard password protec�on features -
see Protec�ng a document with a password (sec�on 12.3)

Along with the Internal Chronology you should also distribute some instruc�ons about how to use it. At
the very least, you should explain that the document contains macros and might produce a warning
message about them when it is opened, or even prevent them from running. You might like to use the
text in the Sample Covering Email / Le�er (sec�on 12.5) or Sample Covering Email for Chronolator Data
Entry users (sec�on 12.6).

The Using Chronolator Documents Help provides some hints and �ps about working with Word tables in
general and Chronolator in par�cular. It also explains how a Local Administrator can distribute the
Internal Chronology to a number of people and merge their input into a Composite Chronology to be
returned to you.

View the online version at www.chronolator.com/help/using-chronolator-documents.

5.4 CREATING A COMPOSITE CHRONOLOGY DOCUMENT
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Start a new Composite Chronology by
pressing the New Composite Chronology
bu�on on the Chronolator toolbar:

The rest of the process is described in the Step by Step Guide in the Using Chronolator Documents Help.
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6 WORKING WITH CHRONOLATOR DOCUMENTS
Chronolator Documents (including the Online Workbench) are Microso� Word documents with extra
features. All standard Word features are available and work in the usual way.

Word might require you to allow some ac�ons before it ini�alises Chronolator. In par�cular:

you might need to Enable Edi�ng if the document opens in Protected View
you might need to Enable macros, depending on your macro security se�ngs

You will also need to accept the terms of the Chronolator licence if you have not already done so since
you opened Word.

For details, please refer to the following:

Protected View (sec�on 12.1.1)
Enabling macros (sec�on 12.1.2)
Licensing (sec�on 12.1.3)

A�er you have completed any of the above tasks that are required, Chronolator adds a toolbar (sec�on
4) to the Word Ribbon.
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7 WORKING WITH THE BROWSER TOOLS
The Chronolator Browser Tools provide a way to process chronologies in a Web Browser (Chrome and
Firefox for example).

It is important to note that only the so�ware resides on the Web. Your chronologies stay on your
computer, completely under your control. Their confiden�ality is not compromised.

However, the Browser tools and Chronolator for Word use different types of file. This sec�on describes
how to transfer chronologies between them.

TRANSFER FROM WORD TO THE CHRONOLATOR BROWSER TOOLS
On the Chronolator toolbar, press Publish > JSON to produce a file in JSON (JavaScript Object Nota�on)
format:

Note that the JSON file is unencrypted and can be read by humans with a simple text editor. If you want
to prevent this, open it in any of the Chronolator Browser Tools and save it: this will produce a txt file
that only the browser tools can interpret.

If you want to further protect the chronology with a password, refer to the Help in the Browser Tool.

TRANSFER FROM THE CHRONOLATOR BROWSER TOOLS TO WORD
(OR EXCEL OR OTHER PROGRAM)
There are two ways to transfer data from the Chronolator Browser Tools to Word:

the Chronolator Conversion Tool
via the Clipboard

Use the Conversion Tool if you want to use Chronolator for Word features. If you only want to produce a
plain Word document, you can use the Clipboard.

USING THE CONVERSION TOOL

The conversion tool works on a JSON file created by the Browser Tool. Refer to the Browser Tool's Help
for details of how to create one.
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If you already have a Chronolator for Word licence, you will find the Conversion Tool in the
ChronologySetup folder.

If you do not, you can download it from www.chronolator.com/downloads/download-conversion-
tool.htm.

In either case, the aforemen�oned Web page includes instruc�ons about how to use it.

USING THE CLIPBOARD

Step 1 - copy the chronology to the Clipboard

Refer to the Help in the Browser Tool for details of how to copy the chronology.

Step 2 - paste the Clipboard to another program

You can paste the clipboard into another applica�on such as Microso� Word or Excel (or, indeed, any
other).

You can paste the clipboard by using the Paste bu�on on the Home tab, or by pressing Ctrl+V.

The following instruc�ons assume you are pas�ng into a new, blank Microso� Office document.

A�er pas�ng

Excel should automa�cally convert the data when you paste it into a blank spreadsheet.

Word will also do so, as long as you press Keep source forma�ng op�on on the small Paste Op�ons
menu:

(for more informa�on, see h�ps://�nyurl.com/paste-into-word).

If you paste the clipboard as plain text, you will need to convert it to a table like this:

Select All (Ctrl+A)
Convert the selec�on to a table using the Insert tab, choosing Table > Convert text to table and
using all the defaults

Line breaks: Word and Excel

If your table contained line breaks, they will have been transformed into the ` character .

Do the following to change them back into line breaks:
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Select All (Ctrl+A)
Open the Replace dialog (Ctrl+H)
Type ` in the Find What box. You should find it at the top le� of your keyboard

(In Word): Type ^p in the Replace with box. You should find the ^ character with Shi�+6
(In Excel): Type Ctrl+Shi�+J in the Replace with box

Press Replace All

7.1 INCORPORATING THE BROWSER TOOLS INTO YOUR
WORKFLOW

In �me, all the principal func�ons of Chronolator for Word will be replicated in the Chronolator Browser
Tools , and you will be able to conduct a review using them from start to finish. Un�l then, you might
need to switch between the Word and Browser Tools versions at different stages of the review.

This topic is about how best to incorporate the Browser Tools into your workflow. For details about
the different file formats used by Chronolator for Word and the Browser Tools, and how to convert
one to the other, see Working with the Browser Tools (sec�on 7).

THINGS TO CONSIDER

WHAT CAN EACH PRODUCT DO?

Chronolator for Word can do nearly everything that the Browser Tools can - defining a new chronology,
entering data into it, checking it for errors, merging chronologies and so on.

The Define browser tool is used to define a new chronology, providing the same features as the Case
Details Wizard in the Chronolator Online Workbench.

The Data Entry browser tool provides everything needed to enter events into a chronology.

The browser Reviewer's Tool provides features that Word cannot easily do, such as graphical �melines.

STRENGTHS AND WEAKNESSES OF THE BROWSER TOOLS

In general, the Browser Tools improve on Word. They use more modern technology that allows them to
run faster, and they can be more quickly updated with new features and problem fixes. Prin�ng a
coloured tabular chronology is about the only thing that Word can do be�er.

Some par�cular advantages of the Browser Tools:

they use JSON or txt file formats that are much less likely to be rejected by email systems as
containing malicious so�ware
a standard Word Internal Chronology includes many tools that are not required to enter a
chronology, and this can be confusing to some people. In contrast, the Data Entry tool provides a
much simpler interface
the Data Entry tool stops invalid events being added to a chronology. The only errors that can
occur are events that are out of sequence
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As well as providing the �melines men�oned above, the Reviewer's Tool includes sophis�cated
search and filter capabili�es. Its speed improvement over Word when using these in large files is
drama�c.

WHAT FACILITIES DO YOUR PARTNER AGENCIES HAVE AND WANT TO USE?

Strange as it might seem, not everyone has Microso� Word, for example.

If they do, do they want to use all the facili�es Chronolator for Word provides?

Do you need to protect the chronology with a password?

SUGGESTED WORKFLOWS
Here are some suggested workflows based on the above considera�ons.

All of them begin by producing a suitable file for the Browser Tools as follows.

On the Chronolator toolbar, press Publish > JSON to produce a file in JSON (JavaScript Object Nota�on)
format:

You can circulate the JSON file as it is, but if you want to protect the file with a password, you will need
to:

open it in the Data Entry tool
add a password using the facility on the Se�ngs tab
save the result using the Save as text bu�on on the Finish tab
send the result to your partners

You might like to adapt and use the Sample Covering Email for Chronolator Data Entry users (sec�on
12.6).

WHEN YOUR PARTNER AGENCIES DO NOT WANT TO USE CHRONOLATOR FOR
WORD  

When they have finished using the Data Entry tool, ask them to use one of the bu�ons on the Finish tab
to save a  JSON or txt file and return the result to you.

You will need to convert the file into a Chronolator for Word document. If they return a JSON file, this is
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simply a ma�er of using the Chronolator Conversion Tool, which you will find in the ChronologySetup
folder. If, however, they return a txt file, before you can use the Conversion Tool you will first need
to open the txt file in Data Entry and save it as JSON using the Save as text bu�on on the Finish tab.

WHEN YOUR PARTNER AGENCIES WANT TO USE CHRONOLATOR FOR WORD  

In this case, you should send them a JSON file and tell them that they can download the Chronolator
Conversion Tool from www.chronolator.com/downloads/download-conversion-tool.htm, which also has
instruc�ons about using it.

When they have finished their work, they can either return you a Chronolator for Word document, or
convert it to JSON or txt in the same way you did at the start of the process.
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8 APPENDIX A – TROUBLESHOOTING
If your problem is not described here, please see the FAQ page on the Chronolator website
www.chronolator.co.uk/faq.htm, which contains informa�on about problems encountered a�er this
document was produced.

Many of the ac�ons described below depend on what version of Word you are using. If you are unsure,
refer to How can I tell which version of Word I am using? (sec�on 2.2)

8.1 THE CHRONOLATOR TOOLBAR DOES NOT APPEAR
The Chronolator toolbar should be added to any other custom toolbars on the Add-Ins tab on the
Ribbon.

Before Word adds it, it might require you to allow some ac�ons. In par�cular:

you might need to Enable Edi�ng if the document opens in Protected View
you might need to Enable macros, depending on your macro security se�ngs

You will also need to accept the terms of the Chronolator licence if you have not already done so since
you opened Word.

For details, please refer to the following:

Protected View (sec�on 12.1.1)
Enabling macros (sec�on 12.1.2)
Licensing (sec�on 12.1.3)

8.2 THE CHRONOLATOR TOOLBAR HAS DISAPPEARED
If the Chronolator toolbar was there when you opened the document but is no longer visible, you might
have hidden the Ribbon by accident.

If so, click the Add-ins tab to show the Chronolator toolbar.

MAKING THE RIBBON PERMANENTLY VISIBLE
You can make the Ribbon stay visible if you want. Right-click between any of the tab labels (Home and
Insert for example) and un-�ck Minimise the Ribbon or Collapse the Ribbon:

Word 2010
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Word 2013

Word 2016 and later

You can also toggle the Ribbon between visible and invisible states by pressing Ctrl + F1 .

8.3 THE CHRONOLATOR TOOLBAR DOESN'T HAVE ALL ITS
BUTTONS

Chronolator only puts bu�ons on the toolbar if they can do something useful in the current document -
for example, since the only thing you can do with a fresh Composite Chronology is to import tables into
it, the only bu�ons are Import Tables and Help.

Having said that, Word hides bu�ons from the toolbar or ribbon if your window is too small. To get them
back, just widen or maximise the window.

8.4 THE CHRONOLATOR PROGRESS BAR DISAPPEARS
Chronolator informs you about the
progress of most tasks using the
Progress Bar. For example, while
you are checking tables it might look
something like this:

Some�mes, if you are processing a very large file on an older computer with not much memory, or on a
slow network, the progress bar can disappear from �me to �me. If this happens, it is o�en possible to
make it visible again by double-clicking on the document's icon in the Windows Task Bar.

Disappearance of the progress bar does not affect the processing which is being done. When it has
finished, Chronolator will display a comple�on message as usual.

8.5 SLOW PROCESSING
If you find that Chronolator is running unusually slowly, it can some�mes help to close Word and start
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again - don't forget to save your work first!

For example, on one occasion while Version 3 was being developed, it was found that upda�ng
sequence numbers in a large file was taking almost four minutes. A�er saving, closing, and re-opening
the document, the �me went down to just over one minute.

It is also worth no�ng that the Chronolator Browser Tools run many func�ons significantly faster
than Chronolator for Word. See Working with the Browser Tools (sec�on 7). 

8.6 CONFLICTS WITH WORD ADD-INS
Some�mes Word add-ins conflict with Chronolator. When that happens, you can start Word without
loading add-ins and then open the Chronolator Document from Word's Open dialog.

STARTING WORD WITHOUT LOADING ANY ADD-INS
You can start Word without any add-ins by following the instruc�ons below.

Locate the Windows key. It is usually somewhere
between the Ctrl and Alt keys near the bo�om le�
of your keyboard.

Hold down the Windows key and press R  to open
the Run dialog

Type winword /a in the Open box

Note: there is a space between winword and
/a
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Press OK For most installa�ons of Office, Word should start
without any add-ins.

If so, you have completed this procedure and can
now open the Chronolator Document from
Word's Open dialog.

In some installa�ons, Windows
will be unable to find Word

If so, press OK then con�nue as follows.

Press the Browse … bu�on

Word's Browse dialog will be
displayed

Find Winword.exe

The default loca�ons are as follows:

Word
2016

C:\Program Files\Microso� Office\Root\Office16 or
C:\Program Files (x86)\Microso�
Office\Root\Office16

Word
2013

C:\Program Files\Microso� Office\Office15 or
C:\Program Files (x86)\Microso� Office \Office15

Word
2010

C:\Program Files\Microso� Office\Office14 or
C:\Program Files (x86)\Microso� Office \Office14
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In the Browse dialog, click
WINWORD.EXE, and then press
Open

The Run dialog will be
redisplayed, with the path to
Winword.exe in the Open box,
surrounded by quote marks

Click in the Open box, use the
right arrow bu�on to reposi�on
the inser�on point to the right of
the closing quota�on mark at the
end of the path statement, and
type a space followed by /a

Press OK to open Word Word will start without any add-ins. You can now open the
Chronolator Document from Word's Open dialog.
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9 APPENDIX B - CHRONOLATOR MESSAGES
 

9.1 MESSAGE TYPES
Chronolator messages fall into two main types:

Messages confirming the results of some processing or offering the user a choice of ac�ons. These
messages are displayed on the Chronolator Message Form and have unique reference numbers. They
are described in the next sec�on.
Brief messages describing errors found when checking tables. These messages appear as Tool�ps
when the mouse is hovered over a table error, and are also listed at the bo�om of a Chronolator
Document a�er Check Tables discovers errors. They are described in Check Table Error Codes (sec�on
9.10).

THE MESSAGE FORM
The Chronolator Message Form has three main parts:

 

The upper part contains the main
message.

The middle part contains a more detailed
explana�on of the message, and suggests
what ac�ons might be appropriate.

The lower part displays a four-digit
Message Reference Number, which can be
used to locate the message in the
following sec�ons.

All the messages are shown below, together with further informa�on and suggested ac�ons if appropriate.

9.2 MESSAGES 1000 - 1999
Messages in this range are issued when impor�ng, merging and sor�ng tables.

Setting Up Chronolator Documents 38

© 2023 Berrick Computing Ltd. All Rights Reserved.



1000 Tables imported

 All Chronolator tables have been imported. You can merge them into a single table
by using the 'Merge Tables' bu�on on the Chronolator toolbar.

Further
Informa�on

Chronolator has imported tables from one document into another. The imported
tables appear a�er those which were originally in the target document.

You can con�nue impor�ng more tables, or merge the tables together.

 

1003 Invalid document

 The file you chose is not a Chronolator document and cannot be imported into a
new Composite Chronology.

Please refer to the descrip�on of this message in the documenta�on for sugges�ons
about what to next.

Further
Informa�on

A new Composite Chronology has no informa�on about the requirements for a
par�cular review un�l you import a Chronolator Document.

Once this informa�on is in place, Chronolator will import matching tables from any
Word document; but the first document you import into a blank Composite
Chronology MUST be a Chronolator Document. 

 

1004 Invalid document

 The file you chose is not a Chronolator document, or it has internal inconsistencies
which are described below. It cannot be converted.

Possible causes You are trying to convert a document that does not contain the informa�on
Chronolator needs, or in which that informa�on has been corrupted.
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1005 Case References are different
            Composite Chronology: CaseReference1
            Imported Chronology: CaseReference2

 Press OK to con�nue with import, or Cancel

Further
Informa�on

Every Chronolator Document is assigned a Case Reference by the Case Review
Administrator in order to warn against accidentally merging documents which relate
to different cases. The Case Reference of each document is shown in the message.

Possible causes You are trying to import tables from a non-Chronolator document, or from a
Chronolator document which has a different Case Reference.

Possible ac�ons Press OK if you want to con�nue with the import, or Cancel if you do not.

 

1006 Cannot import document into itself

 Chronolator cannot import a document into itself.
Please choose a different document to import.

 

1010 'Must-fill' columns are different in source and target documents

 Press OK to con�nue with import, or Cancel

Further
Informa�on

Although Chronolator has found tables which have the correct column headings, the
'Must-fill' columns are different.

Possible causes You are trying to import tables from a non-Chronolator document, or from a
Chronolator document from a different case which has different 'Must Fill' columns.

Possible ac�ons Press OK if you want to con�nue with the import, or Cancel if you do not.
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1015 No Data Tables found in document

 There are no tables in the document which match the required column headings.

Further
Informa�on

Issued when you process a document which has no tables with the required column
headings.

Possible causes If you are checking, sor�ng, or forma�ng a document, the table headings might
have been accidentally changed.

If you are impor�ng a document, the headings in the document you are trying to
import do not match those in the composite.

Possible ac�ons Check what column headings Chronolator expects, and if appropriate change table
headings in the problem document to match the defined headings.

You can find the expected headings by using the Admin > Show Document Details
bu�on.

Alterna�vely, use the Admin > New Table bu�on to add a table with the correct
column headings to the bo�om of the document. A�er you have done so, either
copy any data you have already entered into the new table, or copy the heading row
from the new table into that of the old one.

 

1016 No events found in document

 There are no events in the document

Further
Informa�on

Issued when the only Chronolator table in the document contains no events.

Possible causes If there is a table that does contain events, its headings have been changed.

Possible ac�ons See the sugges�ons for Message 1015 in this sec�on above
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1020 Document level mismatch

 The document you are trying to import cannot be imported into this document as it
was created with a higher level of Chronolator.

Create and use a new Composite Chronology using the higher level document for
this review. Refer to the manuals if you require step-by-step instruc�ons.

Further
Informa�on

Chronolator documents are generally backwards-compa�ble; that is, newer version
documents can read older version ones. However, it is not possible to guarantee
forwards-compa�bility.

 

1025 Conflic�ng and Mul�ple Defini�ons

 The document you are trying to import includes some abbrevia�ons and defini�ons
which could be confused with those in this one. Although Chronolator will keep
track of what was defined where, reading the document might be confusing.

If you want to use the anonymisa�on / personalisa�on feature in the Composite
Chronology, you must first resolve these conflicts by changing the abbrevia�ons in
one of the documents.

Press Go To List to review the conflicts, OK to con�nue with the import, or Cancel.  

Further
Informa�on

Chronolator will import a document with conflic�ng and mul�ple entries in the
Abbrevia�ons Glossary, but if you want to anonymise or personalise the document
you must resolve these anomalies. You will be able to do this in the Composite
Chronology a�er import, but it is recommended that you do it in the source
document before impor�ng it.

 

1026 Conflic�ng Defini�ons - Import Cancelled

 You have chosen to save the conflic�ng defini�ons in a new document. Chronolator
assumes this is because you want some �me to review them, and will therefore
cancel the Import.

Further
Informa�on

Issued if you press Go To List in response to Message 1025.
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1030 User-defined sequence column found

The document you are trying to import includes a user-defined Sequence column. It
was probably added because the person comple�ng the document wanted to be
exact about the order of certain events whose exact �mes were unknown.
Chronolator can either add a Sequence column to the table(s) in this document, or
delete the one in the document being imported.

Press Add to add a Sequence column to the table(s) in this document, Delete to
delete the one in the document being imported, or Cancel.

Further
Informa�on

Recommenda�on: Press Add to add a Sequence column to the Composite
Chronology so that you can con�nue to preserve the correct order of events. A�er
you have done so, you can use the Tools > Sequencing menu to add numbers to the
remaining events.

If you choose Delete, the Sequence column remains in the document being
imported but is not carried across.

 

1031 Sequence column not found

 The document you are trying to import does not include a Sequence column, but is
suitable for import in all other respects. Chronolator can either delete the Sequence
column from the table(s) in this document, or add one to the document being
imported.

Press Add to add a Sequence column to the table(s) in the document being
imported, Delete to delete the one in this document, or Cancel

Further
Informa�on

Recommenda�on: Assuming you have deliberately added a Sequence column to the
Composite Chronology, press Add to add one to the document being imported (the
document itself is unchanged, just the version of it in the Composite Chronology).
A�er you have done so, you can use the Tools > Sequencing menu to add numbers
to the imported events.
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1033 Unable to import

 Chronolator cannot import anything into this document because of the following
internal inconsistencies in its structure:

 <list of inconsistencies>

Further
Informa�on

The document you are trying to import is a Chronolator Document, but it has some
internal inconsistencies. These are listed in the message.

Possible causes The internal variables which Chronolator uses to describe the document structure
have been lost or corrupted. This can some�mes happen when impor�ng
documents across a slow network, or it might happen if Word failed while the
document was being edited some�me in the past.

Possible ac�ons if the document is on a slow network, copy it to your desktop and try impor�ng
the copy
try Repairing the document as described in Recovering Corrupted Chronolator
Documents  in the Using Chronolator Documents Help

 

1050 Your entry <newPrefix> is similar to the exis�ng prefix <oldPrefix>

 Chronolator will not use exactly what you entered.

You can either import the document using the exis�ng prefix, or you can choose a 
completely different one.

Press OK to use the exis�ng prefix.

To choose a different one, press Cancel and then Import Tables again.

Further
Informa�on

Chronolator keeps the list of Source Prefixes �dy.

Possible causes Your Composite Chronology already contains informa�on from agency <oldPrefix>,
and you are trying to import another document with a similar Source Prefix.

For example, If a Composite Chronology already has an agency Berrick New Town
Clinic, Chronolator will stop you impor�ng another chronology with a similar prefix
such as Berrick Newtown Clinic.
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1051 Invalid Source Prefix

 The '>' character cannot be used when defining a Source Prefix.

Please press 'Import Tables' again.

Further
Informa�on

Chronolator uses the '>' character to separate the parts of mul�-level sources.

 

1052 Invalid Source Prefix

 A Source Prefix cannot start with a Author Note tag.

Please press 'Import Tables' again.

Further
Informa�on

The characters #, ^, ¬, and ~ are used to iden�fy  Author Notes in the Chronolator
Reviewer's Tool.

 

1100 Tables merged

 All Chronolator tables have been merged into a single table. You can sort the new
table into the correct sequence by using the 'Sort Tables' bu�on on the Chronolator
toolbar.

Further
Informa�on

Chronolator has merged all the tables in the document.

The next thing you might want to do is to sort the events into chronological order.
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1110 Cannot merge tables

 A non-Chronolator table has been found in between the Chronolator tables. The
offending table is selected. Please move or delete it and try again.

Further
Informa�on

The document contains more than one Chronolator table, and among them is a
non-Chronolator table.

Possible causes An ordinary Word table has been inserted by accident.

A Chronolator table has had its headings changed.

Possible ac�ons If the table contains no data for import, delete it or move it to the end of the
document.

If the table does contain data for import, correct its headings so that Chronolator
recognises it as a Chronolator table.

 

1120 Mul�ple chronology tables found

 This document contains more than one chronology table.

Press 'Merge' if you want Chronolator to merge the tables and sort them before
processing.

Press 'Don't Merge' to process each table individually.

Press 'Cancel' to return to the document without doing anything.

Further
Informa�on

It is normal to have mul�ple chronology tables when assembling a Composite
Chronology, but in other circumstances it might come about by accident.
Chronolator therefore checks how many tables are in a document before most
major processes, and if there are more than one it offers to merge and sort them
before con�nuing.
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1200 Table sorted

 Events should now be in Date and Time sequence.

Some date and �me formats can prevent a successful Sort. If that happens, use the
Format Dates bu�on to put dates in the all-digital format and then sort the table
again. You can put the dates back to your preferred format a�erwards if you wish.

If you know the order of events on a day but not exactly when they occurred, you
can use a Sequence column to put them in order. You can make one using the Tools
> Sequencing > Add Column bu�on.

Further
Informa�on

Chronolator puts events with unspecified Times or End Dates before those specified
with greater detail if the sort is Ascending, or a�er them if it is Descending.

See Using a Sequence column  in the Using Chronolator Documents Help for details
about using a Sequence column.

(If the document contains mul�ple tables,  the message heading will be Tables
merged and sorted or Tables sorted individually according to the response to
Message 1120).

 

1201 Table sorted

 Events should now be in Date and Time sequence.

Some date and �me formats can prevent a successful Sort. If that happens, use the
Format Dates bu�on to put dates in the all-digital format and then sort the table
again. You can put the dates back to your preferred format a�erwards if you wish.

If you know the order of events on a day but not exactly when they occurred, you
can use the first column to put them in order.

Further
Informa�on

Chronolator puts events with unspecified Times or End Dates before those specified
with greater detail if the sort is Ascending, or a�er them if it is Descending.

See Using a Sequence column  in the Using Chronolator Documents Help for details
about using a Sequence column.

(If the document contains mul�ple tables,  the message heading will be Tables
merged and sorted or Tables sorted individually according to the response to
Message 1120).
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1300 Dates forma�ed

 All dates have been forma�ed to one of Chronolator's standard formats.

If you would like future releases of Chronolator to offer alterna�ve date formats
please use the sugges�on form on our web site www.chronolator.com.

Further
Informa�on

Chronolator uses two main formats for dates:

dd mmm yyyy (e.g. 01 Feb 2005). This format takes up a small amount of space
while being unambiguous about months and days (compared to, say 01.02.05 –
is that the first of February or the second of January?)
yyyy-mm-dd (e.g. 2005-02-01). This is the ISO 8601 format. It takes even less
space than the previous format and has the advantage of being an Interna�onal
Standard, but most people find it harder to read

The day of the week can be added to both of these formats.

If you would like to be able to set other formats, please contact us via our web site.

9.3 MESSAGES 2000 - 2999
Messages in this range are issued by the Online Workbench.

2000 Cannot find Conversion Tool

 Find the file < chronolator-conversion-tool.docm > from your original Chronolator
installa�on and copy it into folder <folderName>.

Further
Informa�on

When you create a new Chronology Document, Chronolator looks for the file
chronolator-conversion-tool.docm. It issues this message if it cannot find it.

Possible causes You have opened the Online Workbench directly from the installa�on zip file. You
need to Extract All Files from the installa�on file and open the extracted Online
Workbench.

The Conversion Tool document has been moved or deleted.

The Online Workbench has been moved, but not the Conversion Tool.

Possible ac�ons Extract All Files from the installa�on zip file.

Find the file chronolator-conversion-tool.docm and copy or move it into the folder
shown in the message.
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2001 Cannot copy Conversion Tool

 The Conversion Tool (chronolator-conversion-tool.docm) is open and cannot be
copied. Please close it and try again.

Further
Informa�on

When you create a new Internal or Composite chronology, Chronolator tries to open
chronolator-conversion-tool.docm. It issues this message if the file is already open.

Possible causes You have opened chronolator-conversion-tool.docm.

Possible ac�ons Close chronolator-conversion-tool.docm and try again.

 

2002 Conversion Tool is wrong version

 The Conversion Tool Document (chronolator-conversion-tool.docm) is the wrong
version for this Online Workbench. Please copy the correct Conversion Tool into
folder folderName.

Further
Informa�on

When you create a new Internal or Composite chronology, Chronolator opens
chronolator-conversion-tool.docm. It issues this message if the file is a different
version from the Online Workbench.

Possible causes You have upgraded the Online Workbench without also upgrading the Master
Chronology.

Possible ac�ons Install the correct version of chronolator-conversion-tool.docm in the folder shown
in the message.

 

2003 Cannot find Master Chronology Text

 Find the file < ChronolatorMasterChronologyText.docx > from your original
Chronolator installa�on and copy it into folder <folderName>.

Further
Informa�on

When you create a new Internal chronology, Chronolator looks for the file
ChronolatorMasterChronologyText.docx. It issues this message if it cannot find it.

Possible causes You have opened the Online Workbench directly from the installa�on zip file. You
need to Extract All Files from the installa�on file and open the extracted Online
Workbench.

The Master Chronology Text document has been moved or deleted.

The Online Workbench has been moved, but not the Master Chronology Text

Possible ac�ons Install ChronolatorMasterChronologyText.docx in the folder shown in the message.
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2010 Invalid document

 The file you chose is not a Chronolator document and cannot be used as a model.
Please choose another file, or use the Chronolator defaults.

Further
Informa�on

You can only use a Chronolator document as a model for a new one.

Possible causes You opened an ordinary Word document when choosing an exis�ng file to use as a
Model in the Case Details Wizard.

Possible ac�ons Use a Chronolator document as a model, or use the Chronolator defaults.

 

2011 Invalid password

 The password you supplied is incorrect. Please try again, choose another file, or use
the Chronolator defaults.

Further
Informa�on

You entered the wrong password for a protected file.

Possible ac�ons When Chronolator redisplays the Open dialog: enter the correct password, choose
another file, or use the Chronolator defaults.

 

2015 Invalid document

 The Chronolator document you chose has internal inconsistencies and cannot be
used as a model. Please choose another file, or use the Chronolator defaults.

Further
Informa�on

Informa�on about the structure of a Chronolator Document is stored in document
variables. The document you have chosen as a model has inconsistencies in this
informa�on, and it is not possible to use it as a Model.

Possible causes Word might have ended abnormally when it last processed the document, causing
internal inconsistencies.

Possible ac�ons Use a different Chronolator document as a model, or use the Chronolator defaults.
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2016 Invalid document

 The Chronolator document you chose is a blank Composite Chronology and cannot
be used as a model. Please choose another file, or use the Chronolator defaults.

Further
Informa�on

Informa�on about the structure of a Chronolator Document is stored in document
variables. A blank Composite Chronology does not contain these variables, and it is
not possible to use it as a Model.

Possible ac�ons Use a different Chronolator document as a model, or use the Chronolator defaults.

 

2020 Cannot write document details in preamble

 The area in the Master Chronology preamble where Chronolator writes informa�on
about the headings in this Chronolator document cannot be found.

This affects only the document preamble: the table and all Chronolator features will
work correctly, and it is safe to distribute the document.

Further
Informa�on

When first installed, the Master Chronology Text document
ChronolatorMasterChronologyText.docx  contains a bookmarked area in which
Chronolator writes informa�on about the column headings in a new Internal
Chronology. That area cannot now be found.

Chronolator does not write informa�on about the headings in the preamble, but
con�nues to create the remainder of the Internal Chronology.

Possible causes You have customised the Master Chronology and have deleted the area and its
associated bookmark.

Possible ac�ons If you want Chronolator to include informa�on about the column headings, revert
to the original Master Chronology and redo your changes, being careful not to
delete the relevant area and bookmark.

9.4 MESSAGES 3000 - 3999
Messages in this range are issued when Chronolator checks the tables in a Chronology.
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3000 Errors found in document (n)

 Rest the mouse over the box with a cross to see a brief descrip�on of each error.

Use the bu�ons on the Chronolator toolbar to go from one error to the next, or
press the Go To List bu�on to view a complete list.

When you have corrected the errors, press the Check Tables bu�on again to remove
the highligh�ng.

Further
Informa�on

You pressed the Check Tables bu�on, and Chronolator has found n errors.

Errors are highlighted in Turquoise, Yellow, or Purple. You can scroll from one error
to the next using the naviga�on bu�ons towards the right of the Chronolator
toolbar, or see a complete list of them by pressing the bu�on to the right of the
naviga�on bu�ons.

Chronolator does not check for errors as you type, so you must Check Tables a�er
making any correc�ons in order to remove the highligh�ng.

Possible causes Refer to Check Table Error Codes (sec�on 9.10) for informa�on about each error
detected by Chronolator.

Possible ac�ons No immediate ac�on is necessary, but you should ensure that all errors are
corrected before returning or publishing the document.

 

3001 Some rows had the wrong number of columns - fix these first

 Chronolator has corrected the number of columns in at least one row. However, it
could not be sure which entry should go in which column. You should review these
rows now and make sure their entries are in the right places.

It is important to do this now, because now that they have the right number of
columns they will not be caught in future checks unless they have other errors.

For ease of iden�fica�on, the corrected rows are displayed with white text on a
purple background.
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3005 Document contains errors - do you want to close it?

 Please ensure that all errors are corrected before returning or publishing this
document.

Press Cancel to resume edi�ng the document and correct them now.

Press OK to close the document and correct them later.

Further
Informa�on

Chronolator has checked the document as you closed it, and has found errors. The
errors are highlighted in Turquoise, Yellow, or Purple. You can scroll from one error
to the next using the naviga�on bu�ons towards the right of the Chronolator
toolbar, or see a complete list of them by pressing the bu�on to the right of the
naviga�on bu�ons.

Possible causes Refer to  Check Table Error Codes (sec�on 9.10)  for informa�on about each error
detected by Chronolator.

Possible ac�ons No immediate ac�on is necessary, but you should ensure that all errors are
corrected before returning or publishing the document. If you want to correct them
straight away, press Cancel. If you want to do it later, press OK.

 

3010 Checked - no errors found

 Chronolator has checked all the tables in this document and found no errors.

Further
Informa�on

You pressed the Check Tables bu�on, and Chronolator has found no errors in this
document.

The bu�ons on the Chronolator toolbar which can be used to scroll through errors
are disabled.
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3011 No changes found since previously checked

 No data table appears to have changed since Chronolator last checked this
document.

Press Cancel to resume edi�ng.

Press Check to re-check the document.

Further
Informa�on

To save �me, Chronolator makes a quick check to see whether anything has
changed since the last run of Check Tables.

It is possible that this check does not detect a change. If you are sure you have
updated the table press Check to re-check the document.

 

3012 Document contains no events

 None of the Chronolator tables in this document has any events.

Further
Informa�on

Chronolator does not create a Custom or Analysis document if there are no events
in a chronology.

 

3013 Document contains text a�er chronology tables

 The area a�er the chronology tables is reserved for Chronolator and will be
overwri�en if you con�nue.

Press Cancel to return to the document and review the text Chronolator found. If
you want to keep it, move it before the chronology tables before you check the
tables again.

Press OK to delete the text and con�nue.

Further
Informa�on

You pressed the Check Tables or Duplicates bu�on. Chronolator will overwrite
whatever follows the chronology tables in the document if you press OK.
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3015 Error checking cancelled

 Please ensure that you check for errors before returning or publishing this
document.

Also please note that if you have corrected some previous errors they might s�ll be
highlighted un�l the next �me you check the document completely

Possible causes You pressed the Cancel bu�on while Chronolator was checking for errors.

Possible ac�ons No immediate ac�on is necessary, but you should ensure that all errors are
corrected before returning or publishing the document.

 

3020 Processing cancelled

 No changes have been made.

Possible causes You pressed the Cancel bu�on while Chronolator was processing. Any changes
made before you pressed Cancel have been backed out.

 

3025 n duplicates found

 You can use the bu�ons on the Chronolator toolbar to go from one duplicate to the
next.

Further
Informa�on

Chronolator found n duplicated rows and highlighted them.

Possible ac�ons You can scroll from one duplicate to the next using the naviga�on bu�ons towards
the right of the Chronolator toolbar.

 

3030 n duplicates deleted

  

Further
Informa�on

Chronolator found n duplicated rows and deleted them. The rows cannot be
recovered.

Possible ac�ons If you want to be able to recover deleted rows in future, �ck the Copy Deleted Rows
op�on when dele�ng duplicates.
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3031 n duplicates deleted

 Chronolator has saved the deleted rows. Press the 'Go to List' bu�on to view them.

Tip: to re-import them, save the list in a convenient loca�on and use the
c8ImportSpecial_1 macro. Refer to this message in the manuals for more
informa�on

Further
Informa�on

Chronolator found n duplicated rows and deleted them. The rows can be recovered.

Possible ac�ons Press Go to List to view the saved rows (if you have already moved on before
reading this, you will find the document is open in the current Word session - look
for 'Documentn' where n is a number).

Column widths in the saved list might be different from those in the Chronology
Document, which can present a problem when copying them back in. There are a
couple of ways to circumvent this:

if you want to recover every row and are working in a Composite Chronology:
save the list as a new document
press Advanced > c8ImportSpecial_1 to import the saved document without
se�ng a Source Prefix
merge the tables

if you want to recover only selected rows or are working in an Internal
Chronology:

in the saved list, select and copy the row(s) you want to recover
go back to the Chronology Document
add the same number of rows to the bo�om of the chronology table
press in the first blank cell you added to the chronology table
paste the copied row(s)

 

3035 No duplicate rows

 Chronolator has checked all the tables in this document and found no duplicated
rows.

Further
Informa�on

Un�l Chronolator Version 3, iden�cal rows separated by other non-blank rows were
not iden�fied as duplicates. From Version 3 onwards, duplicate rows will be found
wherever they occur in a table.
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3100 Chronolator table contains ver�cally merged cells

 A Chronolator table in this document contains some ver�cally merged cells. The
table will be ignored.

Use the Check Tables bu�on to find the problem cells.

Further
Informa�on

A Chronolator table in the current document contains a cell which spans more than
one row; this is called a 'ver�cally merged cell'. Chronolator is unable to process
tables containing ver�cally merged cells.

Any other Chronolator tables in the document will be processed as usual.

Possible ac�ons Use the Check Tables bu�on to find ver�cally merged cells.

Insert one or more rows. Copy and paste any required text into them, then delete
the rows containing ver�cally merged cells.

 

3103 Chronolator table contains ver�cally merged cells

 <document name>cannot be imported because a table in it contains some ver�cally
merged cells.

Open the document and use its Check Tables bu�on to find the problem cells.

Further
Informa�on

This message can be issued when you try to import a document into a new
Composite Chronology.

A Chronolator table in the document being imported contains a cell which spans
more than one row; this is called a 'ver�cally merged cell'. Chronolator is unable to
process tables containing ver�cally merged cells.

Chronolator will not import a document containing any Chronolator tables with
ver�cally merged cells into a new Composite Chronology.

Possible ac�ons A�er Import processing completes, open the problem document. Correct the
problem as described under the 'Possible Ac�ons' for Message 3100. Retry the
Import.
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3105 Chronolator table contains invalid rows

 <document name> cannot be imported because a table in it contains some rows
with the wrong number of columns.

Open the document and use its Check Tables bu�on to find the problem rows.

Further
Informa�on

<document name> is a valid Chronolator Document, but a table in it has at least one
row with the wrong number of columns.

Possible ac�ons Open the problem document. Press its Check Tables bu�on and then take the
ac�ons suggested in Message 3001. Retry the Import.

 

3107 <process> processing cancelled - invalid table

 Word failed to process a Chronolator table. No changes have been made to this
document.

Retrying the process might succeed. If not, use the Check Tables bu�on to find (and
possibly automa�cally correct) the problem.

Further
Informa�on

In normal running, this message indicates that a Chronolator table contains at least
one column with cells of varying widths. Chronolator is unable to run <process> on
such tables.

This message can also occur under a peculiar set of circumstances with versions of
Word prior to 2013. In that case, retrying <process>  can some�mes be successful.

The Chronolator document will be restored to the state it was in before <process> 
processing began.

Possible ac�ons Retry <process>.

If that does not work, use the Check Tables bu�on, which as part of its processing
rebuilds the table, and then try <process>again.

If the problem persists, contact your administrator and ask them to request support.
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3108 <process> processing cancelled - non-uniform table

 At least one of the tables in this document has a row with the wrong number of
columns. Please correct this and try again.

Hint: Use Check Tables to find the problem.

Further
Informa�on

Chronolator has found a table which, although it has the correct headings, contains
at least one row with the wrong number of columns.

Possible causes Cells have been merged.

A row has been added with the wrong number of columns.

Possible ac�ons Open the offending document and press Check Tables. Chronolator will correct any
rows with the wrong number of columns and highlight them. You should check that
Chronolator has put the relevant informa�on in the right columns before saving the
corrected document.

 

3110 Chronolator table contains nested table

 A Chronolator table in this document contains at least one nested table. The table
will be ignored.

Use the Check Tables bu�on to find the nested table(s).

Further
Informa�on

A Chronolator table in the current document contains a cell which in turn contains a
nested table. Chronolator is unable to process such tables.

Any other Chronolator tables in the document will be processed as usual.

Possible ac�ons Use the Check Tables bu�on to find nested tables. Having found one, select it and
convert it to text. Cut and paste informa�on into the correct columns.
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3113 Chronolator table contains nested table

 <document name> cannot be imported because a table in it contains at least one
nested table.

Open the document and use its Check Tables bu�on to find the nested table(s).

Further
Informa�on

A Chronolator table in <document name>  table contains a cell which in turn
contains a nested table. Chronolator is unable to process such tables.

Nothing will be imported.

Possible ac�ons Open <document name>  and use its Check Tables bu�on to find nested tables.
Having found one, select it and convert it to text. Cut and paste informa�on into the
correct columns. Retry the import.

 

3120 Chronolator table contains unexpected number of rows

Expected: m Found: n:

 When Word prepared the table for processing, it did not find the expected number
of rows.

No data will have been lost, but some might be misplaced (either on its own new
row, or appended to the previous row).

Further
Informa�on

To make some of its processes faster, Chronolator gets Word to store tables in an
internal array.

This message is issued if the number of elements in the array does not match the
number of rows in the table.

Possible ac�ons If you encounter this message a�er pressing the Check Tables bu�on, look for any
rows that are highlighted in purple, or check the error list for error code c8n100
(sec�on 9.10).

If it occurs in other circumstances, pressing the Check Tables bu�on might show
other errors resul�ng from the poten�ally misplaced data (for example, invalid
dates).

If Check Tables shows no errors, look through the document for misplaced data.
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3200 Bulleted or Numbered list has been reforma�ed

 A Chronolator table in this document contained some bulleted or numbered lists.
These can cause problems when documents are merged. The bullets or numbers
have been removed.

Rather than using Word's list features, you could use 'o' characters or dashes for
bullets, or use ordinary numbers.

9.5 MESSAGES 4000 - 4999
Messages in this range are issued when Chronolator checks the status of your licence.

4000 Mul�ple licences found

 Chronolator found more than one licence file. Please delete old ones.

Look in the same folder as the Online Workbench for files whose names begin
'Chronolator40Licence'.

Further
Informa�on

The Online Workbench found more than one licence file in its folder.

Possible causes You have received a new licence and installed it in the correct folder without
dele�ng the old licence.

Possible ac�ons Delete the old licence(s), then close and reopen the Online Workbench.

 

4001 Mul�ple licences found

 Chronolator found more than one licence file. Please delete old ones.

Look in the same folder as the Conversion Tool for files whose names begin
'Chronolator40Licence'.

Further
Informa�on

The Conversion Tool found more than one licence file in its folder.

Possible causes You have received a new licence and installed it in the correct folder without
dele�ng the old licence.

Possible ac�ons Delete the old licence(s), then close and reopen the Conversion Tool.
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4005 Invalid licence

 Chronolator found a licence file, but it is not valid. Please re-install or delete it.

Look in the same folder as the Online Workbench for a file whose name begins
'Chronolator40Licence'. Replace that file with the licence supplied to you, or simply
delete it if you only want to evaluate Chronolator.

Possible causes Licences are supplied as .txt files.  The file might have accidentally been edited.

Possible ac�ons Find your original licence and copy it into the same folder as
ChronolatorOnlineWorkbench.docm.

 

4006 Invalid licence

 Chronolator found a licence file, but it is not valid. Please re-install or delete it.

Look in the same folder as the Conversion Tool for a file whose name begins
'Chronolator40Licence'. Replace that file with the licence supplied to you, or simply
delete it if you only want to evaluate Chronolator.

Possible causes Licences are supplied as .txt files.  The file might have accidentally been edited.

Possible ac�ons Find your original licence and copy it into the same folder as chronolator-
conversion-tool.docm.

 

4020 Licence Expired

 Your licence has expired and this func�on is not available.

Further
Informa�on

Running Chronolator features requires a licence. Without a valid licence, only
standard Microso� Word features are available.

Possible causes Licence has expired.

Possible ac�ons Depends on what document issued this message:
if issued by the Online Workbench, install a new licence file. then close and
reopen the Online Workbench. Details about how to get a licence can be found
on the Chronolator Web site at www.chronolator.com/licence.htm
if issued by an Internal or Composite Chronology, ask the Case Review
Administrator to send you a new licensed copy, and then copy the old document
into the new one
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4030 Licence Expired

 Your licence has expired. All standard Microso� Word features remain available, but
Chronolator features are disabled.

Please visit www.chronolator.com for details of how to obtain a new licence.

Further
Informa�on

Refer to Message 4020.

 

4040 Invalid Extension Password

 The password you entered is not valid

Please contact your administrator.

Further
Informa�on

When a Chronology Document licence expires, you can enter a password to extend
it.

Possible causes The password you entered is invalid.

Possible ac�ons Obtain a valid password from the person who sent you the document.

9.6 MESSAGES 5000 - 5999
Miscellaneous messages.

 

5100 Publish document?

 Publishing a document makes a plain Word copy without any Chronolator code.
Readers of the copy will not have to agree to any licence terms. A�er Chronolator
has created the copy, you will be prompted to save it.

Press OK to con�nue, or Cancel.

Further
Informa�on

If you circulate a Chronolator document, readers will have to think about macros
and accep�ng licence terms when opening it. Use this bu�on to produce a plain
Word document which contains no Chronolator code.

Possible ac�ons Press OK to create a non-Chronolator copy, or Cancel.
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5105 Cannot publish a document to the same name

 Publishing the file using this name would make it lose all its Chronolator func�ons.

Please try the save again using a different name.

Further
Informa�on

You have tried to publish a Chronolator Document using the same name as the
document. Overwri�ng it in this way would stop its Chronolator func�ons from
working.

Possible ac�ons Choose a different name for the published document.

 

5110 Could not copy styles

 Chronolator encountered a Word error when trying to copy some of the styles used
in this document. Pagina�on, text size and other forma�ng a�ributes might be
different in the published version.

Try Publishing a second �me when this a�empt has completed: it will probably work
as expected.

Possible causes Internal error in Word when Publishing a Chronolator Document

Suggested
ac�ons

Retry Publishing.

If that fails, try Publishing to a different loca�on.

 

5115 Publishing cancelled

 Report produc�on was cancelled at your request.
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5120 Publishing cancelled

 At least one date/�me combina�on in this document is not valid. Chronolator is
therefore unable to calculate elapsed �mes.

Correct the date/�me combina�on and try Publishing again.

(Sugges�on: use the Check Tables bu�on to find any invalid date/�me
combina�ons).

Further
Informa�on

When you choose one of the Elapsed formats when Publishing a Custom
chronology, Chronolator needs to calculate the difference between when an event
started or ended and the start of the chronology. It can only do this if all non-blank
dates and �mes are valid.

Possible ac�ons Press the Check Tables bu�on to find any invalid date/�me combina�ons, and
correct them.

 

5130 Show Chronolator error details in published document?

 This document contains error highlights and / or a list of errors generated the last
�me it was checked. Do you want to include them in the published version?

(If you do not, please note that page numbers might be different in the published
version).

Further
Informa�on

It is up to you whether to include details of errors in a published document.
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5140 Cannot create Analysis Document

 Sequence numbers are missing or invalid.

If the chronology document does not have a Sequence column, add one using
Tools > Sequencing > Add column.

If it does, update it using
Tools > Sequencing > Update – sequen�al

A�erwards, try Publish > Analysis again.

Further
Informa�on

An Analysis document requires valid sequence numbers in every event.

Possible causes a table does not contain a Sequence column
non-numeric, blank, or duplicate entries in the Sequence column

 

5141 Cannot create Analysis Document

 Chronolator could not determine the date boundaries of table <tableNum>.

Further
Informa�on

In order to analyse a table, Chronolator needs to determine the earliest and latest
events.

Possible causes Either the earliest or latest date in the table, or both, cannot be determined.

Possible ac�ons Use the Check Tables bu�on to ensure all dates in the table are valid.

 

5143 Cannot create Analysis Document

 Chronolator found an invalid date in the event with reference number <eventRef>.

Further
Informa�on

In order to analyse a table, all dates must be valid.

Possible causes The date of the event with reference number <eventRef> is invalid.

Possible ac�ons Correct the date.
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5144 Cannot create Analysis Document

 Chronolator found an invalid source prefix in the event with reference number
<eventRef>

Further
Informa�on

In order to analyse a table, all Source Prefixes must be valid.

Possible causes The Source Prefix of the event with reference number <eventRef> is invalid.

Possible ac�ons Correct the Source Prefix.

 

5200 Unsupported Word version

 Chronolator requires Microso� Word 2000 or later.

Press OK to con�nue without Chronolator, or Cancel to exit Word.

Further
Informa�on

Earlier versions of Word are not supported by Microso�, so we would be unable to
offer Chronolator support if the root cause of a problem was Word itself.

Possible ac�ons Press OK to close the document.

Ask your IT department to upgrade Word. They might be persuaded to do so by
reading the informa�on about Microso�'s support lifecycle for Office programs at
h�ps://support.microso�.com/en-gb/lifecycle/search?alpha=office.

 

5210 Document type changed

 Chronolator works by running macros, so documents must be saved as .doc or
.docm types. Chronolator will change the document to the correct type before
saving it.

If you want to save the document as another type, use the Chronolator Publish
bu�on to make a plain Word copy and then save the Published copy in your desired
format.

Further
Informa�on

Saving a document in a format which does not support macros would stop it being
able to use Chronolator.

Suggested
ac�ons

Publish the document to make a plain Word copy which you can then save in any
other format.
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5220 Performance recommenda�on

 Chronolator performs best when Word uses an op�on that improves the
performance and reliability of any document stored on a network drive.

Press OK if you would like Word to use it.

Further
Informa�on

Word XP introduced a performance improvement op�on for documents stored on a
network. When the op�on is set on, a network document is copied to a secure
loca�on on your computer when you open it. You work on that copy. When you
save or close the document, Word moves it back to its network loca�on. This can
lead to drama�c improvements in performance, and also provides enhanced
protec�on against network failure.

Unfortunately, when Microso� introduced this op�on they did not make it the Word
default. Chronolator can set it for you if it is not already on.

The op�on applies to all documents, not just Chronolator ones.

Suggested
ac�ons

Press OK to allow Chronolator to set the op�on
Close and re-open the document when prompted

Turning the
op�on off

If you decide later that you want to turn the op�on off, you can do so as follows:
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 Word XP and 2003

On the main Word menu bar, press Tools > Op�ons, then press the Save tab:

Un-�ck Make local copy of files stored on network or removable drive.

Press OK.
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 Word 2007 and later

Open the Op�ons dialog (see Opening the Word Op�ons Dialog (sec�on 12.4) in The
Trust Center (sec�on 12.4)).

Press Advanced and scroll down to Save.

Un-�ck Copy remotely stored files onto your computer, and update the remote file
when saving.

Press OK.

 

5221 Performance recommenda�on

 Chronolator has set the op�on. Please close and re-open this document to allow it
to take effect.

Further
Informa�on

See Message 5220.
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5230 Change tracking alert!

 <document name> is using Word's Track Changes feature. Tracking changes can
cause severe problems when processing tables.

Press OK to accept all tracked changes and turn change tracking off, or Cancel if you
want to review them.

Further
Informa�on

Using Tracked Changes with tables can cause problems in any Word document, not
just a Chronolator one. Microso� are aware of this, but at the �me of wri�ng there
is no fix on the horizon.

 

5231 <process> cancelled - change tracking ac�ve

 <document name> is using Word's Track Changes feature.

The Tracked Changes feature can cause severe problems when processing tables.

Further
Informa�on

The named <process> was cancelled because change tracking is ac�ve in the
document <document name>.

Possible causes You replied Cancel to Message 5230.

You replied OK to Message 5230, but Chronolator was unable to turn off tracked
changes.

Suggested
ac�ons

Review the tracked changes if you wish, then retry the cancelled process and reply
OK to Message 5230.

 

5232 Unable to determine Tracked Changes status in <document name>

 Chronolator could not determine whether Tracked Changes is on in the document
because it appears to be locked by another user.

To be on the safe side, Chronolator will assume that Tracked Changes is on.

The Tracked Changes feature can cause severe problems when processing tables.

Possible causes Someone else is edi�ng the document and Chronolator could not determine
whether Change Tracking is on.

Suggested
ac�ons

Close the document and wait for the other person to close it as well. Reopen the
document.
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5233 Unable to turn off Tracked Changes in <document name>

 Chronolator could not turn off Tracked Changes.

This is probably because the document has been protected.

The Tracked Changes feature can cause severe problems when processing tables.

Possible causes <document name> has been protected so that the Tracked Changes feature cannot
be turned off.

Suggested
ac�ons

Turn off the protec�on. You might need to supply a password.

The relevant protec�on feature can be found in various places:
Word 2013 and later- the Track Changes dropdown or the Restrict Edi�ng
bu�on on the Review tab of the Ribbon
Word 2010 - the Restrict Edi�ng bu�on on the Review tab of the Ribbon
Word 2007 - the Protect Document dropdown on the Review tab of the Ribbon

 

5310 Web connec�on error.

 Word cannot open the Web site.

Please check your connec�on is OK.

Further
Informa�on

A Chronolator Web site cannot be found.

Possible causes You do not have an open Internet connec�on, or your organisa�on might have
limited your access.

Possible ac�ons Connect to the Internet or contact your IT department to grant you access to our
website as appropriate.
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5320 Cannot save the document using the name you chose

 A document with that name is already open in Word.

Please try the save again using a different name.

Further
Informa�on

Word does not allow you to save a document with the same name as one which is
already open.

Possible causes You have tried to save a document using the same name as an open document.

Possible ac�ons Retry the save using a different name.

 

5321 Cannot overwrite Chronolator system file

 Saving the file using this name might overwrite documents which Chronolator needs
to func�on.

Please try the save again using a different name.

Further
Informa�on

Chronolator will not let you save a file using one of its own reserved file names
(chronolator-conversion-tool and ChronolatorOnlineWorkbench).

Possible ac�ons Retry the save using a different name.

 

5322 Permission Denied

 You do not have Write access to the requested folder.

Please try to save the file in a different folder.

Further
Informa�on

You have tried to save the file in a folder to which you do not have Write access

Possible ac�ons Save the file in a folder to which you do have Write access, such as My Documents.

If you think you should have Write access to the folder, contact your IT department.
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5323 File might be temporary

 This file looks like a temporary one, or is in a temporary folder. If you are unaware of
this you might not be able to find it a�er you close it.

A�er you press OK, you will be asked to save the document using another name and
folder.

Please refer to the manuals if you frequently get this message.

Further
Informa�on

You might have become a vic�m of a bug in Word.

Possible ac�ons Save the file in the right place with the right name.

If the message is issued o�en, please ask your Administrator to contact Berrick
Compu�ng, quo�ng Message 5323.

 

5400 Internal inconsistencies in Chronolator document

 Chronolator has found internal inconsistencies in this document, which are detailed
below.

These may stop Chronolator func�ons working. Standard Word features are
unaffected.

<list of inconsistencies>

Further
Informa�on

Informa�on about the structure of a Chronolator Document is stored in document
variables. Inconsistencies in this informa�on might stop some Chronolator func�ons
working. However, standard Word func�ons should not be affected.

Possible causes The document is stored on a slow network.

Word might have ended abnormally when it last processed the document, causing
internal inconsistencies.

Possible ac�ons If the document is on a slow network, close it and try opening it again. If that does
not work, copy the document to your Desktop and work on that copy; remember to
move it back to the network when you have finished.

If the document is indeed corrupted, open a valid Chronolator Document with the
correct table headings (for example, the original document sent to you by an
Administrator), and copy the contents of the problem document into it. Save this
new document and use it from now on.
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5402 Unable to create table

 Chronolator cannot create a new table in this document because of following
internal inconsistencies in its structure:

<list of inconsistencies>

Further
Informa�on

See Message 5400 for sugges�ons about how to resolve these inconsistencies.

 

5403 Unable to set styles

 Chronolator could not set some document styles because the file appears to be
locked by another user.

This will only affect the fonts used to display any error messages at the end of the
document.

Further
Informa�on

If there are any error messages at the end of the document, they might not be
displayed in the usual font.

Possible causes Someone else is edi�ng the document.

Suggested
ac�ons

Close the document and wait for the other person to close it as well. Reopen the
document.

 

5500 Clipboard Unavailable

 Chronolator could not access the clipboard. Another applica�on is probably using it.

Press OK to try again, or Cancel.

9.7 MESSAGES 6000 - 6999
Chronolator issues these messages when an unexpected error occurs.
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6000 Unexpected processing error

 Please note the informa�on below and report it to us using the form on our
website: www.chronolator.com/bug-form.htm.

<problem descrip�on>

Further
Informa�on

Chronolator has encountered an unexpected error. The problem descrip�on
provided will help diagnose the error.

Possible ac�ons Please note the problem descrip�on and what you were doing at the �me and send
the details to us using the form on the website. The more informa�on you can
provide the be�er. The Document Details and Word Environment reports will be
useful if you can produce them a�er closing and reopening the document. See
Document Details and Word Environment Reports in the Using Chronolator
Documents help or manual.

9.8 MESSAGES 7000 - 7999
Chronolator issues these messages when you use the Anonymisa�on and Highligh�ng features.

 

7000 Glossary contains similar entries

 Anonymisa�on and Personalisa�on are not possible because the Abbrevia�ons
Glossary contains abbrevia�ons and / or defini�ons that are too similar to each
other..

You can update the glossary and related text using Tools > Glossary > Edit.

Press Review to see the relevant entries, or OK to dismiss this message.

Possible ac�ons See Changing an abbrevia�on in the Using Chronolator Documents help or manual.

 

Setting Up Chronolator Documents 76

© 2023 Berrick Computing Ltd. All Rights Reserved.

https://www.chronolator.com/bug-form.htm


7010 Warning!

 Forma�ng introduced while using the <feature> feature can be lost when Checking
or Merging Tables, processing Sequence numbers, and in some other circumstances
which are described in the 'Using Chronolator Documents' manual.

Press OK to con�nue, or Cancel so that you can save your work and review the
manual before trying again.

This message will not be shown again during this session. 
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Further
Informa�on

The Bold, Italic, Underline forma�ng which can be applied using the
Anonymisa�on feature, and the colours applied by the Highlight Source feature can
some�mes be lost.

This happens because Chronolator makes some compromises between convenience
and speed. When forma�ng and colouring are lost it would be possible for
Chronolator to reapply it automa�cally, but this could take �me in a large file.
Instead of doing this, it warns you it might happen and directs you here for more
informa�on.

The following bu�ons and processes will ALWAYS destroy forma�ng and colouring:

Check Tables
Tools > Duplicates > Highlight
Tools > Duplicates > Delete
Tools > Sequencing > Add
Tools > Sequencing > Update - sequen�al
Tools > Sequencing > Update - group by day

The following bu�ons and processes will SOMETIMES destroy forma�ng and
colouring because they rely on the Source Prefixes in the Source of Informa�on
column being in a uniform state (for example, having the right number of spaces
between words and being in the correct case). As long as the column is unchanged
from one run to the next, forma�ng and colouring will be unaffected:

Tools > Glossary > Edit > Change
Tools > Glossary > Edit > Delete
Tools > Glossary > Edit > Review
Tools > Glossary > Anonymisa�on and Review > Anonymise
Tools > Glossary > Anonymisa�on and Review > Personalise
Tools > Glossary > Anonymisa�on and Review > Review
Tools > Highlight Source > Define and Do > OK

The following bu�ons and processes will SOMETIMES destroy forma�ng and
colouring, either because the table has cells of different widths or because a bug in
Microso� Word erroneously thinks it has:

Tools > Sequencing > Delete
Tools > Sequencing > Clear
Import Tables (if the impor�ng document has a Sequence column but the
imported one does not, or vice versa)
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Possible ac�ons Do not use the Anonymisa�on and Highlight Source features un�l you have no
further need for the bu�ons and processes known ALWAYS to destroy forma�ng
and colouring before using.

Avoid changing the Source of Informa�on column.

 

7030 Abbrevia�on Not Used

 The selected abbrevia�on and defini�on are not used in the text.

 

7031 Abbrevia�ons Not Used

 The selected abbrevia�ons and defini�ons are not used in the text.

 

7032 Nothing to anonymise

 The selected abbrevia�on is not used in the text.

OR

The selected abbrevia�ons are not used in the text.

 

7033 Nothing to personalise

 The selected abbrevia�on is not used in the text.

OR

The selected abbrevia�ons are not used in the text.

Further
Informa�on

If the message includes the text 'with the specified forma�ng', you have asked
Chronolator only to look for abbrevia�ons which have Bold, Italic, Underline
forma�ng by �cking the box on the Anonymisa�on form.

If the Use forma�ng checkbox is �cked when a document is being
Personalised, only those occurrences of an abbrevia�on which are forma�ed
like this will be changed.
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9.9 MESSAGES 8000 - 8999
Chronolator issues these messages when you use Chronolator Add-ins.

 

8000 Add-in loaded successfully

 Please refer to the documenta�on accompanying the add-in for details about what
it does and how to use it.

 

8010 Add-in failed to load

 <document>

<error message> 

Further
Informa�on

Add-in <document> failed to load.

The reason is given in  <error message> 

Possible ac�ons Ensure that <document> is a valid Chronolator Add-in for the version of Chronolator.

If you think it is, contact your Administrator and ask them to report the problem to
Berrick Compu�ng. Give them as much detail as possible.

 

8020 Cannot open document - a Chronolator Add-in is loaded

 Only one Chronolator document can be open while a Chronolator Add-in is loaded.

9.10 CHECK TABLE ERROR CODES
These messages appear as Tool�ps when the mouse is hovered over a table error, and are also listed at
the bo�om of a Chronolator Document a�er Check Tables discovers errors.
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c8n100 This row contained the wrong number of columns. Chronolator has rec�fied this,
but you should check that the each entry is under the right heading

Further
Informa�on

The number of columns in this row was different from the number of column
headings. Chronolator has added or deleted columns to rec�fy this. No data will
have been deleted, but it might not be in the correct column.

Possible ac�ons Review where Chronolator has put the original data, and move it into another
column if necessary.

 

c8n120 This column is blank, but must always be completed. Add some text.

Further
Informa�on

The Case Review Administrator has deemed it mandatory that this column should
always be completed.

Possible ac�ons Add text to the column.

 

c8n125 'As Above', 'See Above', or di�o marks are not allowed.

Further
Informa�on

This can seem annoying when you are entering many similar events into an Internal
Chronology. However, remember that the Administrator will probably merge your
chronology with others. When merged chronologies are sorted, 'As Above' and
similar rows may well become separated from their previous predecessors.

Possible ac�ons Copy and paste text from the previous row.

 

c8n130 Cell is ver�cally merged. Copy any text to another row or rows and delete all rows
containing this cell.

Further
Informa�on

The table cell in ques�on spans more than one row; this is called a 'ver�cally
merged cell'. Chronolator is unable to process tables containing ver�cally merged
cells.

Possible ac�ons Insert one or more rows. Copy and paste any required text, then delete all rows
containing the problem cell.
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c8n135 Cell contains a nested table. Convert the nested table to text.

 

Further
Informa�on

The table cell in ques�on contains a nested table. This can happen if you select the
relevant op�on when pas�ng from on table into another.

Possible ac�ons Convert the nested table to text, and make sure the informa�on it contains is under
the correct column headings.

 

c8n140 The '>' character is not allowed in this column.

Further
Informa�on

Chronolator uses the '>' character to keep track of the Source of Informa�on in a
Composite Chronology. It is, therefore, not allowed in the Source of Informa�on
column in an Internal Chronology.

Possible ac�ons Use a different character.

 

c8n145 Invalid Source

Further
Informa�on

The Source of Informa�on column contains an invalid Source Prefix. Source Prefixes
are assigned when you import a chronology document and cannot be changed
a�erwards.

Possible ac�ons Press Admin > Show Document Details to see the list of prefixes which are valid in
this document.

 

c8n210 Invalid date, or invalid date format. Try another format (e.g. '01 feb 2006' or
'01.02.06').

Further
Informa�on

Chronolator cannot interpret the date in this cell. It might be in a recognisable
format but be invalid (e.g. '32 May 2007'), or Chronolator might not recognise the
format.

Possible ac�ons Enter a date in a recognisable format. Chronolator recognises most common date
formats.
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c8n220 Invalid �me, or invalid �me format. Try another format (e.g. '1.20 am', '0120', or
'01.20').

Further
Informa�on

Chronolator cannot interpret the �me in this cell. It might be in a recognisable
format but be invalid (e.g. '25:00'), or Chronolator might not recognise the format.

Possible ac�ons Enter a �me in a recognisable format. The message text indicates a number of
formats that Chronolator recognises.

 

c8n230 Event ends before it starts.

Further
Informa�on

None.

Possible ac�ons Change the start or end dates / �mes of the event.

 

c8n240 Start of event is out of sequence.

Further
Informa�on

None.

Possible ac�ons Check the informa�on about when the event started. If it is correct, you can use the
Sort Tables bu�on to put the event in the proper place in the table.

Some�mes you might get many of these errors. If so, go to the first one and then
look at the event immediately before it; it is o�en that one which is the root cause
of the problem.

 

c8n250 End of event is out of sequence.

Further
Informa�on

None.

Possible ac�ons Check the informa�on about when the event finished. If it is correct, you can use
the Sort Tables bu�on to put the event in the proper place in the table.
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c8n300 At least one abbrevia�on is not defined. Change the abbrevia�on, or use the Tools
> Glossary > Edit bu�on to define a new one. Put mul�ple abbrevia�ons on
separate lines, or separate them with commas.

Further
Informa�on

None.

Possible ac�ons As suggested in the note.
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10 APPENDIX C - LICENSING
Chronolator is licensed so�ware. You can evaluate its features without having a licence, but the
documents it creates include a watermark on every page. If you do not want these watermarks to
appear, Chronolator must be licensed.

When you open the first Chronolator Document in a par�cular Microso� Word session, a form is
displayed where you can accept or decline the licence terms. The Licensee and Expiry Date are shown
on the form, and the full terms of the licence can be displayed by pressing the View Licence bu�on. If
you do not accept them, the document will close.

Chronolator Documents and the Chronolator Online Workbench are licensed in different ways.

ONLINE WORKBENCH LICENCE
When you buy a licence to use the Chronolator Online Workbench, you are given a small text file whose
name begins Chronolator50Licence.

The licence is specific to a par�cular purchaser, and the licence file should not be distributed to anyone
else except as allowed in the licence terms.

Details about how to get a licence for the Online Workbench can be found on the Chronolator Web site
at www.chronolator.com/licence.htm.

To install the licence, copy it into the same folder as the Online Workbench. The Online Workbench
propagates the licence informa�on into the Chronolator Documents it creates.

CHRONOLATOR DOCUMENT LICENCE
Chronolator Document licences are stored internally in a Chronolator Document when it is created by
the Online Workbench or the Browser Define tool.

LICENCE PERIODS
A Chronolator licence is valid for a specified period.

For the Online Workbench, the period is contained in the licence file
Internal Chronologies are licensed for up to six calendar months from the day they are created,
subject to a maximum of one month a�er the Online Workbench licence expires
Composite Chronologies created by the Online Workbench are licensed for the same period as
the Online Workbench
Composite Chronologies created by the Browser Define tool are licensed for the same period as
that tool
Composite Chronologies created by Local Administrators using the facili�es included in an
Internal Chronology expire at the same �me as that Internal Chronology

Internal Chronologies created by Berrick Compu�ng Ltd under the terms of a Single Case licence are
licensed for the period agreed with the purchaser

Setting Up Chronolator Documents 85

© 2023 Berrick Computing Ltd. All Rights Reserved.

https://www.chronolator.com/licence.htm


WHAT HAPPENS WHEN A LICENCE EXPIRES

When a licence expires, all the standard Microso� Word features con�nue to func�on, but:

the Chronolator toolbar and bu�ons do not appear
no Chronolator features are available

Chronolator Documents whose licence has expired can be imported into licensed Composite
Chronologies as if they were s�ll licensed.

LICENCE EXTENSION

Unavailability of records and other factors can some�mes delay the comple�on of a Chronolator
Document beyond its expiry date. Chronolator Documents therefore provide simple ways to extend a
licence without having to contact Berrick Compu�ng Ltd. The exact process depends on where the
chronology was ini�ally defined - by Chronolator for Word or by the browser Define tool.

Documents created by the Chronolator Online Workbench in Chronolator for Word

Star�ng 30 days before such a Chronolator Document expires, a warning appears and an Extend Licence
bu�on is added to the Licence Acceptance form. Pressing it prompts the user to enter an Extension
Password, which is supplied along with the Online Workbench licence. Entering the correct password
extends the licence for up to three calendar months, subject to a maximum of one month a�er the
Online Workbench licence expires.

Documents created by the Chronolator Define Tool and converted to Chronolator for Word

Star�ng 30 days before such a Chronolator Document expires, a warning appears. You can export the file
to JSON using the Publish > JSON bu�on on the toolbar.

If the document has actually expired, an Export JSON bu�on is added to the Licence Acceptance form.
Pressing it exports the chronology to JSON.

In either case, open the JSON file in one of the Chronolator Browser Tools and update the licence. You
can then export it to JSON and use the Chronolator Conversion Tool to get it back into Word format. 
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11 APPENDIX D - HOW CHRONOLATOR DEALS WITH EVENTS
WITH IMPRECISE DATES OR TIMES

In the real world, events begin and end on exact dates and at exact �mes. In a chronology, not all this
informa�on might be known for a par�cular event. Indeed, in some chronologies, the administrator
might decide not to collect some of this informa�on at all.

Chronolator always ensures that the Start Date of event is specified, but the Start Time, End Date and
End Time are o�en missing. How does it deal with such events?

ASSUMPTIONS

INDIVIDUAL EVENTS

When informa�on about the exact start or end of an event is missing, Chronolator makes the following
assump�ons so that it can be processed.

if Start Time is missing, it is assumed to be midnight (00:00)
if End Date is missing, it is assumed to be the same as Start Date
if End Time is missing, it is assumed to be the same as Start Time

DURATIONS

Some�mes the elapsed �me between two instants needs to be calculated; for example, the interval
between two events, or between the start and end of a single event. Chronolator assumes that any
informa�on missing in the later instant is the same as that of the earlier one.

ASSUMED INFORMATION IS NEVER DISPLAYED

Whatever assump�ons Chronolator might make about missing informa�on, it will never display those
assump�ons explicitly. For example:

an event which Chronolator assumes to start at midnight, for example, will never include that �me
in any display
a dura�on based upon an assumed �me will only include date-based informa�on

OVERRIDING CHRONOLATOR'S ASSUMPTIONS
Some�mes you might know the order in which events happen even though you do not know their dates
and �me exactly. In these circumstances you can use a Sequence column to ensure that Chronolator
sorts events in the order you specify. The Check Tables bu�on can s�ll be used to check that such
'manually' sorted events are in a valid order. For more informa�on about the Sequence column,
see Using a Sequence column in the Using Chronolator Documents help or manual.
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12 APPENDIX E - SUPPLEMENTARY INFORMATION
 

12.1 OPENING A CHRONOLATOR DOCUMENT
Word might require you to allow some ac�ons before it ini�alises Chronolator. In par�cular:

you might need to Enable Edi�ng if the document opens in Protected View
you might need to Enable macros, depending on your macro security se�ngs

You will also need to accept the terms of the Chronolator licence if you have not already done so since
you opened Word.

For details, please refer to the following:

Protected View (sec�on 12.1.1)
Enabling macros (sec�on 12.1.2)
Licensing (sec�on 12.1.3)

12.1.1 PROTECTED VIEW
Word some�mes opens a document in Protected View, in which no edi�ng is allowed. You must enable
edi�ng if you want to make any changes to the document, let alone use its Chronolator facili�es.

If you get a warning like one of
these, in which the Protected
View warning includes an Enable
Edi�ng bu�on, press it and then
see Enabling Macros (sec�on
12.1.2).

If the Protected View warning
does not include an Enable
Edi�ng bu�on, click on the
warning to discover more
informa�on, and con�nue reading
here.

Setting Up Chronolator Documents 88

© 2023 Berrick Computing Ltd. All Rights Reserved.



The resul�ng display tells you
more about why Word stopped
you edi�ng the document and
offers the opportunity to change
some se�ngs.

In this example, you would press
File Block Se�ngs . . .

. . . and then:

press the circle next to
Open selected file types in
Protected View and allow
edi�ng
press OK a few �mes un�l
you return to the
Chronolator document
close and reopen the
document
press Enable Edi�ng as
shown in the picture above
in this sec�on

The File Block se�ngs in the above example are just some of those which can make a document
open in Protected View. Other se�ngs which ac�vate Protected View can be found in the Trust
Center. See The Trust Center (sec�on 12.4) to discover how to open it.

A�er you have enabled edi�ng in Protected View, you will probably need to Enable Macros.
See Enabling Macros (sec�on 12.1.2) for details.

12.1.2 MICROSOFT WORD MACROS
If, when you open a Chronolator Document, either the Licence (sec�on 12.1.3) is displayed or the
Add-ins tab on the Ribbon has a Chronolator Toolbar, you do not need to read here any further.
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Word might – or might not – warn you that a document contains macros when you open it.

Before it does so, Word might open a document in Protected View.  For more details, see Protected
View (sec�on 12.1.1).

Chronolator works by using Word macros. Because they are computer programs, macros can be used to
propagate and run computer viruses. Word therefore allows you to prevent them running, since for
most documents they are unnecessary. However, for Chronolator they are essen�al.

The following pages show you how to allow Chronolator macros to run without compromising your
computer.

DIGITALLY SIGNED MACROS
Chronolator Version 5.0 macros are 'digitally signed' by Berrick Compu�ng Ltd, which means that Word
checks they have not been tampered with since they were published. If they have been, Word will not
allow them to run.

You can choose to trust all documents signed by Berrick Compu�ng Ltd, in which case Chronolator
Documents will always run macros when you open them. This document shows you how.

Some�mes your IT department might prevent you from making the changes described below. If so,
you might like to ask them to read Group Policy se�ngs for Chronolator Macros.

ENABLING MACROS
Word usually informs you it has disabled macros by displaying a message under the Ribbon, with an
Enable Content bu�on.

If you want to enable macros
just this once, press Enable
Content,  and con�nue reading at
Licensing (sec�on 12.1.3)

If you want always to let
macros run in this document,
press Macros have been
disabled,  and con�nue reading at
Se�ng a level of Trust in this
sec�on.

If Word does not inform you it
has disabled macros, press
File, and con�nue reading at
Se�ng a level of Trust in this
sec�on.
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SETTING A LEVEL OF TRUST

You can choose to enable macros each �me you open a Chronolator Document. If you find that
inconvenient, you can specify a level of trust in them:

To enable macros every �me you open a par�cular Chronolator Document, make it a Trusted
Document
To enable macros every �me you open any Chronolator Document, you can make Berrick
Compu�ng Ltd a Trusted Publisher

You set a level of Trust on the Info
tab in Word's Backstage View.

You can get to Backstage View by
pressing the File tab on the
Ribbon, or by pressing Macros
have been disabled  if Word
displayed a security warning
when you opened a document.

Making a Trusted Document

If you make the document a Trusted Document, Word will automa�cally enable macros in it whenever
you open it.

Setting Up Chronolator Documents 91

© 2023 Berrick Computing Ltd. All Rights Reserved.



In Backstage View:

 

 

 

Press Enable Content to see more
op�ons.

Press Enable All Content.

If the document is on a network
loca�on, Word might warn you
about it.

Press Yes.

Making Berrick Compu�ng Ltd a Trusted Publisher

If you make Berrick Compu�ng Ltd a Trusted Publisher, Word will automa�cally enable macros in this
document and any other Chronolator Documents you receive in future.
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In Backstage View:

 

 

 

Press Enable Content to see more
op�ons.

 

 Press Advanced Op�ons.

In the resul�ng Microso� Office
Security Op�ons display:

 

 

 

 

 

 

 

Press Trust all documents from
this publisher.

Press OK.

WHAT IF I CANNOT ENABLE MACROS?
If for some reason you cannot enable macros, you can s�ll update the document but you will not be able
to use basic Word Save (you will get a message about macros being disabled). In that case, you should
save your changes either:
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by using Save As, or
by closing the document and making the relevant reply when Word asks you if you want to save
changes

12.1.3 ACCEPTING THE LICENCE
Chronolator is licensed so�ware. If
macros have been properly
enabled, a Licence screen is
displayed when you open the
Online Workbench or a
Chronolator Document.

Press OK to con�nue using
Chronolator.

Press Cancel if you do not agree to
the licence terms. The document
will close.

Press View Licence if you want to
read the licence terms.

You are only asked to accept a licence once in a par�cular Microso� Word session.

Further details about licensing can be found in Appendix C (sec�on 10).

12.2 COMPLETING INTERNAL CHRONOLOGY DOCUMENTS
As a Case Review Administrator, you might not be par�cularly involved in entering data in the
Chronolator Documents you create. However, as you might be asked about them it will be useful for you
to know how they work and what they do. Details can be found in the Using Chronolator Documents
manual, or you might like to watch the short video at www.chronolator.com/tutorials/quickstart01-
chronology-recipient/index.htm.

One significant benefit of Chronolator which is described in the manual and video is that a Local
Administrator can distribute an Internal Chronology to a number of people and merge their input into a
Local Composite Chronology to be returned to you.

The flowcharts in the Chronolator Process Summary (sec�on 2.1) illustrate the flow of documents
between administrators and data collectors

12.3 PROTECTING A DOCUMENT WITH A PASSWORD
Word can protect your document with a password. Consult Word Help for full details, but here are two
methods.
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USING THE FILE TAB

Press the File tab on the Ribbon,
and then press Info > Protect
Document > Encrypt with
Password and follow the ensuing
instruc�ons.
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USING SAVE AS

You can also password-protect a
document by clicking on the Tools
> General Op�ons dropdown on
the Save As dialog.

12.4 THE TRUST CENTER
The Trust Center is where you set security op�ons for Microso� Word. It is found in the Word Op�ons
dialog.

OPENING THE WORD OPTIONS DIALOG

Press the File tab
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Press Op�ons

The Word Op�ons
dialog is displayed
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THE TRUST CENTER

In the Word
Op�ons dialog,
press Trust Center,
then press Trust
Center Se�ngs.
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The Macro
Se�ngs bu�on
controls whether
macros can run.
When set as
shown here, it
works in
conjunc�on with
the Message Bar
se�ngs

The Trusted
Publishers,
Trusted Loca�ons,
Trusted
Documents, and
Protected View
bu�ons work
together to
influence when a
document opens
in Protected View.
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To find out more
informa�on about
the se�ngs you
can make a�er
pressing one of
these bu�ons,
click on it and
press ? at the top
right hand corner
of the display to
open Word Help
for the relevant
topic.

12.5 SAMPLE COVERING EMAIL / LETTER

This is some sample text you might want to use in a covering le�er or email. If you want to preserve
the links and forma�ng in it, use the 'Keep Source Forma�ng' or similar op�on when you copy it
into another program such as Word or Outlook. 

Please find a�ached the Serious Case Review document as discussed at the recent panel mee�ng.

It is a special Word document which has been produced using Chronolator, the Chronology Tool. 

The first thing you should do is to save it in a suitable place on your computer or network.

TUTORIAL
If you would like to watch a brief tutorial about using Chronolator, please go to the Web page at
www.chronolator.com/tutorials/quickstart01-chronology-recipient.

MACROS AND THE CHRONOLATOR TOOLBAR
Chronolator uses Word ‘macros’, and if you are prompted about them when you open the document
you should ensure you allow them to run.

When you do, Chronolator will create a toolbar on the Add-Ins tab of the Word Ribbon.

If the toolbar does not appear, please check Appendix A in the Using Chronolator Documents (sec�on
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8.1) manual (see www.chronolator.com/documenta�on/version-5.0 if you have not received a copy) for
possible causes.

If for some reason you cannot enable macros, you can s�ll update the document but you will not be able
to use basic Word Save (you will get a message about macros being disabled). In that case, you should
save your changes either:

by using Save As, or
by closing the document and making the relevant reply when Word asks you if you want to save
changes

WHAT TO PUT IN THE TABLE
The first pages of the Chronolator document give you background to the case and instruc�ons about
what details to enter in the table and where to put them.

The table itself is pre-set with the columns agreed by the Case Review panel.  Fill in the cells in the usual
way using Word.

The document is a Word document, so you can change the font, the column widths, the shading and
other cosme�c forma�ng, but you must not add or remove columns or change the column headings
as Chronolator will be unable to check and process the table. If you do so by accident, you can create a
suitable blank table at the end of the document by pressing Admin > New Table on the Chronolator
toolbar.

ENTERING EVENTS
You can enter events as the records come to hand, and use the Sort Tables bu�on on the Chronolator
toolbar to put them in date order. You can enter dates and �mes as they appear on the original records,
and use the Format Dates bu�on to put them into a consistent format.

ERROR CHECKING
Every �me you close the document, Chronolator will check that the table conforms to the specifica�ons
made by the Case Review Administrator, and that it is in chronological order.

All problems are flagged with the symbol ⌧. Non-blank invalid entries are highlighted in turquoise, and
dates and �mes of out-of-sequence events are highlighted in yellow. If you rest your mouse on the ⌧, a
descrip�on of the error is displayed.

You can scroll from one error to another using the video-like bu�ons on the Chronolator toolbar.

A full list of errors is also created at the end of the document. If you click on the ⌧ next to an error in
the list, Chronolator will go to it in the document.

CAUTION: Do not write anything a�er the error list as it will be deleted the next �me Chronolator
checks the document.

Please ensure that all errors are corrected before returning this document.

You can get Chronolator to check the table at any �me by pressing the Check Tables bu�on, and it also
has many other features which you might find useful.
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COMBINING A NUMBER OF INDIVIDUAL CHRONOLOGIES FROM
YOUR AGENCY
If you want to devolve responsibility for data collec�on to a number of other people, you can forward
this document to them and then use Chronolator to merge their individual chronologies. The Using
Chronolator Documents manual  contains informa�on about this and other features, together with
some useful general �ps about using Microso� Word tables.

FINDING OUT MORE ABOUT CHRONOLATOR
The Using Chronolator Documents manual contains more informa�on, and also some useful �ps about
working with Word tables. There is also a set of video tutorials at www.chronolator.com/tutorials.

If you have any problems please contact Marion West@berrick-LSCB.gov.uk, who will be able to advise
you.

12.6 SAMPLE COVERING EMAIL FOR CHRONOLATOR DATA ENTRY
USERS

This is some sample text you might want to use in a covering le�er or email. If you want to preserve
the links and forma�ng in it, use the 'Keep Source Forma�ng' or similar op�on when you copy it
into another program such as Word or Outlook. 

Please find a�ached the Serious Case Review document as discussed at the recent panel mee�ng.

It is a special text document which has been produced using Chronolator, the Chronology Tool.

The first thing you should do is to save it in a suitable place on your computer or network.

When you have done so, you can start to update it using the Chronolator Data Entry tool
at tools.chronolator.com/enter. The tool has three main tabs:

Get started - this is where you can open the file
Update - add or update events here
Finish - use this tab to save your work

There is also a Se�ngs tab, and a Help one which explains most things about the tool and has a link to
further Help should you need it.

ENTERING EVENTS
You can enter events as the records come to hand, and use the Sort bu�on on the Chronolator toolbar
to put them in date order.

You can enter dates and �mes as they appear on the original records, and use the Format bu�on to put
them into a consistent format.
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ERROR CHECKING
Chronolator will check that any event you enter has all the required informa�on, and will not allow you
to save it if it does not.

If you want to check that events are in chronological order, use the Check bu�on on the toolbar.

RETURNING THE DOCUMENT
When you have finished, please save the file using one of the bu�ons on the Finish tab.

If you have any problems please contact Marion West@berrick-LSCB.gov.uk, who will be able to advise
you.

12.7 ADVANCED MACROS
You should usually only run these macros if asked to do so by Chronolator support staff.

The Advanced menu contains the following tools:

c8EnvironmentCleanup
c8CleanupAddins

Some of these tools are also available using Word's Run Macro facility in case of problems with the
standard Chronolator toolbar.

You run a macro by pressing
Macros on the Developer tab of
the Ribbon:
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You will be asked which macro you
want to run as shown here.

Select it and press Run.

The Developer  tab is only
shown on the Ribbon if the
Word Op�on
Customise Ribbon > Developer
is �cked:

12.7.1 CLEANING UP THE CHRONOLATOR ENVIRONMENT
Chronolator stores some se�ngs in the user area of the Windows Registry, and some�mes saves your
work in hidden Word documents. It removes these things when the last Chronolator document in a
Word session is closed. If this removal were to fail (if Word crashes for example) it might affect opening
the next Chronolator Document.

Macro c8EnvironmentCleanup performs the same clean-up that Chronolator does when it closes
normally.
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12.7.2 UNLOADING CHRONOLATOR ADD-INS
The last Chronolator Document to be closed in a Word session should unload any Chronolator Add-ins. If
it fails to do so, you can run macro c8CleanupAddins, which will unload Chronolator Add-ins but leave
any others you might use in place.
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13 GLOSSARY

A
Abbrevia�ons Glossary

The Glossary contains Abbrevia�ons and their Defini�ons that can be used to anonymise,
personalise, search and navigate the chronology.

Add-in
A stand-alone Word document that can be used to add func�ons to a Chronolator
Document.

Add-ins
A Chronolator Add-in is a stand-alone Word document that can be used to add func�ons to
a Chronolator Document.

Author Note
An event whose Source of Informa�on column begins with one of the of the characters # ^
¬ ~ . Author Notes bypass all event valida�ons except Date and Time.

C
Case Details Wizard
The tool in the Online Workbench that is used to define a new Chronology Document

Case Review Administrator
Someone who sets up a Chronology Document using the Online Workbench

Chronolator Browser Tools

Some tools that use your web browser (e.g. Chrome) to process chronologies.

It is important to note that only the so�ware resides on the Web. Your chronologies stay on
your computer, completely under your control. Their confiden�ality is not compromised.

See  tools.chronolator.com.

Chronolator Document
A document containing one or more tables created by Chronolator

Chronolator Documents
Documents containing one or more tables created by Chronolator

Chronolator Online Workbench
The Word document (ChronolatorOnlineWorkbench.docm) used by a Case Review
Administrator to create Chronolator chronology documents

Chronology Document
A document containing one or more tables created by Chronolator

Composite Chronology

A Chronolator Document containing informa�on from two or more organisa�ons or
departments. O�en referred to as a 'Mul�-Agency Chronology'
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I
Internal Chronology
A  Chronolator Document specific to a par�cular organisa�on or department

ISO 8601
ISO 8601 is an interna�onal standard covering the exchange of date- and �me-related data.
It was issued by the Interna�onal Organiza�on for Standardiza�on (ISO) and was first
published in 1988.

J
JSON
JavaScript Object Nota�on. A text-based format for storing and exchanging data. Can be
read by any text editor, such as Notepad.

JSON parser
So�ware that translates JSON into items that a computer can process.

L
Local Administrator
Someone who distributes an Internal Chronology for others to complete and then merges
the results into a Composite Chronology

London Child Protec�on Procedures
London Child Protec�on Procedures, Edi�on 4, p510 (London Safeguarding Children Board,
2010 (www.londonscb.gov.uk))

M
macros
Macros are a standard feature of all Microso� Office programs. They automate repe��ve
tasks and commands by using Visual Basic for Applica�ons programs.

O
Online Workbench
The Word document (ChronolatorOnlineWorkbench.docm) used by a Case Review
Administrator to create Chronolator chronology documents

P
Preamble
The first couple of pages in a new Internal Chronology. You can update it in any way you
like: Chronolator does not check it.

Protected View
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A standard Word feature that protects your computer from  viruses, worms, or other kinds
of malware that can harm your computer.

Because Chronolator Documents contain macros, and macros can be used to create viruses,
Word some�mes flags them as poten�ally harmful and opens them in Protected View.

R
Ribbon
The area at the top of the Word display

S

Source Prefix
Specifies the agency or organisa�on that provided the informa�on about an event. You are
prompted to enter it when you import a chronology into a Composite Chronology, and
Chronolator adds it to the beginning of whatever is already in the Source of Informa�on
column. 

T
Trust Center
The area in the Word Op�ons dialog that lets you set security op�ons.

txt
A text file produced by one of the Chronolator Browser Tools. Although simple text, only the
Tools can make sense of it.

W
Windows Task Bar
The area along the bo�om of the screen.
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14 INDEX
Accep�ng the Licence,  94

Administra�on

overview,  12-13

Advanced Macros,  103-104

Appendix A – Troubleshoo�ng,  33

Appendix C - Licensing,  85-86

Appendix D - How Chronolator deals with events with imprecise dates or �mes,  87

Cleaning up the Chronolator environment,  104

Column Headings

defining,  13-25

mandatory,  13-25

special,  13-25

Conflicts with Word add-ins,  35-37

Documenta�on,  3

Glossary,  106-108

defining,  13-25

Help,  8-9

Incorpora�ng the Browser Tools into your workflow,  30-32

Internal chronology,  13-25

comple�ng,  94

crea�ng,  13-25

Licensing

Accep�ng the terms,  94

Expired licences,  85-86

Licence types,  85-86

When installing,  10

Macros

Advanced,  103-104
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Conflicts with other programs,  35-37

Enabling,  89-94

Security,  89-94

Microso� Word Macros,  89-94

Online Workbench,  10

Opening a Chronolator Document,  88

Prac�se Using Chronolator,  8

Problem repor�ng,  8-9

Process

diagrams,  4-7

overview,  4-7

Progress Bar

Disappears,  34

Protected View,  88-89

Sample Covering Email for Chronolator Data Entry users,  102-103

Slow processing,  34-35

System requirements

general,  9

Microso� Word,  7-8

The Chronolator progress bar disappears,  34

The Chronolator toolbar does not appear,  33

The Chronolator toolbar doesn't have all its bu�ons,  34

The Chronolator toolbar has disappeared,  33-34

The Online Workbench toolbar,  11

The Trust Center,  96-100

Toolbars

Disappeared,  33-34

Do not appear,  33

Online Workbench,  11

Unloading Chronolator Add-ins,  104-105
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Videos,  8-9

Word

Op�ons dialog,  96-100

Trust Center,  96-100

Versions,  7-8

Working with Chronolator Documents,  27

Working with the Browser Tools,  28-30

Setting Up Chronolator Documents 111

© 2023 Berrick Computing Ltd. All Rights Reserved.


	Table of Contents
	About this document
	Introduction
	What is Chronolator and what does it do?
	A note about Word versions and options
	Practise using Chronolator
	Getting Help
	System Requirements

	Installing Chronolator
	The Online Workbench toolbar
	Chronolator Administration
	Overview
	Creating a new Internal Chronology Document
	Distributing the Internal Chronology Document
	Creating a Composite Chronology document

	Working with Chronolator Documents
	Working with the Browser Tools
	Incorporating the Browser Tools into your workflow

	Appendix A – Troubleshooting
	The Chronolator toolbar does not appear
	The Chronolator toolbar has disappeared
	The Chronolator toolbar doesn't have all its buttons
	The Chronolator progress bar disappears
	Slow processing
	Conflicts with Word add-ins

	Appendix B - Chronolator messages
	Message types
	Messages 1000 - 1999
	Messages 2000 - 2999
	Messages 3000 - 3999
	Messages 4000 - 4999
	Messages 5000 - 5999
	Messages 6000 - 6999
	Messages 7000 - 7999
	Messages 8000 - 8999
	Check Table Error Codes

	Appendix C - Licensing
	Appendix D - How Chronolator deals with events with imprecise dates or times
	Appendix E - Supplementary information
	Opening a Chronolator Document
	Protected View
	Microsoft Word Macros
	Accepting the Licence

	Completing Internal Chronology documents
	Protecting a document with a password
	The Trust Center
	Sample Covering Email / Letter
	Sample Covering Email for Chronolator Data Entry users
	Advanced Macros
	Cleaning up the Chronolator environment
	Unloading Chronolator Add-ins


	Glossary
	Index

